HOME > テクニカルサポート > 製品 一覧 > Gene Construction Kit > チュートリアル
ヒューリンクステクニカルサポート
Gene Construction Kit マニュアル ホームページ | GeneConstructionKit
更新日: 14/03/14

チュートリアル 21:AutoFeature の適用

  1. GCK を起動します。

  2. File > Open から Tutorial files フォルダにある Common Features.gcf という名称のファイルを開きます。図 2.92 のようなダイアログが表示されます。
    図 2.92: AutoFeature File ウィンドウ

    これが新しい AutoFeature ウィンドウです。はじめに、このウィンドウの各種オプションを確認してゆくことにしましょう。エントリとフォーマットはそのままにしておきます。左側にあるパネルに定義されたエントリは選択できるようになっており、それぞれ異なるパラメータを編集できます。GCK が Feature の識別に使用する NameCommentsSequence はユーザー自身で定義できます。Sequence フィールドでは大文字と小文字が区別され(case sensitive)、この使い分けにより検索ルーチーンを厳密に制御することができます。検索文字列においてヌクレオチドを大文字で入力すると、検索結果はターゲットとなる塩基配列 (保存領域) と厳密に一致します。一方、塩基配列がミスマッチを許容する箇所には、小文字で入力されたヌクレオチドを使用できます。小文字で入力された文字がクエリに許容されるミスマッチの割合は、Max. % mismatch allowed に値を入力して定義できます。Protein Sequence オプションをチェックすると、その領域をタンパク質として表示させることができます。また、それに対応するアミノ酸配列もコンストラクトのシーケンスビューに表示できます。詳細は、Tutorial 20: “Find Sequence” をご覧ください。

    Format ボックスには、Feature と一致する DNA セグメントに適用する書式のサンプルが表示されます。Format ボックスをクリックして選択状態にしたら、Format メニューから好みの書式を選択することで、ColorFontLine typeFill pattern を変更することができます。

    画面左の選択ボタンから新規エントリーを追加したり削除することができます。
    AutoFeature ファイルは、メニューから File > Save / Save As… を選択して保存することができますので、ユーザーはプロジェクトごとに独自の AutoFeature ファイル集を作成することができます。

    以上で AutoFeature File の基本概要を理解しましたので、今度は、実際にこれを使って GCK のコンストラクトファイルから Feature を検索させてみることにしましょう。

  3. File > Open を選択して Tutorial Files フォルダにある pCo0GWA.gcc という名称のファイルを開きます。このファイルが、これから Common Feature ファイルを使って注釈を適用するファイルになります。

    このファイルは Region (領域) と Segment (区間) に幾つかの書式がすでに定義されている点にご注意ください。これは Tools > Deluxe Import を使って、GenBank から良く知られたシーケンスを取り込んで作成されたものです (詳しくは、Tutorial 13:Deluxe Import 機能を使用した GenBank シーケンスファイルの読み込み をご覧ください)。

    それでは、AutoFeatures の使い方とその比較を見てゆくことにしましょう。

  4. メニューから Construct > Features > Mark AutoFeatures… を選択して Open ダイアログを開きます。

  5. Tutorial Files フォルダに移動して、Common Features.gcf という名称のファイルを選択して Open ボタンをクリックします。

  6. GCK が Common Features ファイルに定義された feature を使用して pCo0GWA から一致する部分を検索し、それに関連付けられた書式を適用します。結果は、図 2.93 のようになるはずです。
    図 2.93:サンプルの AutoFeatures を適用した後のコンストラクト

    幾つかの feature が重複している点にご注意ください (すなわち、クロラムフェニコール耐性 chloramphenicol resistance と、アンピシリン耐性 ampicillin resistance の領域)。これは、同一の regions や segments またはその両方が二重に適用されたことにより生じた混乱と考えられますので、このファイルをバックアップしたあと Chronography を使用してクリーンな世代を作成します (Tutorial 7: クロノグラフィ (クローニング履歴の再現) をご覧ください)。

  7. まず、先ほど適用した AutoFeatures を削除する必要があります。Edit > Undo を選択して AutoFeatures の適用を前の状態に戻します。このコンストラクトウィンドウでは、まだ何も操作を実行していないので (またはシーケンスビューに切り替えていないので) 、AutoFeatures の適用を Undo すると、前回適用した書式が削除されるはずです。

  8. 次に、現行のセグメント (segment) と領域 (region) データをすべて非表示にして新しい世代を作成し、これを使って AutoFeatures を適用することにします。まずはじめに、Format > Chronography > Start New Generation を選択し、図 2.94 のウィンドウを表示させます。

    図 2.94:AutoFeatures の新しい世代の作成

    上図に示すように、NameComments に内容を入力し、keeping displayed segmentsregionssite markerscomments のいずれも選択されていないことを確認したら OK をクリックします (これにより、segments/regions のエントリも書式も表示されないクリーンなマップが作成されますので、画面の AutoFeatures は feature のみとなります)。

  9. それでは、この表示に Common Features を適用することにしましょう。前と同じやり方で、メニューから Construct > Features > Mark AutoFeatures… を選択して Open ダイアログを開きます。

  10. Common Features.gcf という名称のファイルを選択したら、Open ボタンをクリックします。

  11. プログレスバーが表示され、このファイル内の Feature をスキャンする進捗状況が表示されます。GCK は、pCo0GWA コンストラクトに対して Common Features ファイルに定義された書式を適用します。結果は以下に示す図 2.95 のようになるはずです。
    図 2.95:新しい世代に適用した AutoFeatures

    表示された region / segment を選択して Construct > Get Info (command-I/ctrl-I) を選択することで、識別された feature の内容を確認できます。

    比較するために、メニューから Format > Chronography > Show Previous Generation を選択するか、Format > Chronography のサブメニューから “GenBank Features” という世代 (generation) を選択して、前の画面と交互に切り替えて表示させることができます。

    AutoFeatures に関する詳しい情報は、マニュアルの “AutoFeature ウィンドウ” の章をご覧ください。

以上でチュートリアルは終了です。開いているウィンドウを閉じてください。なお、他の人がこのサンプルファイルを使うかもしれませんので、ここで加えた変更内容は保存しないようご注意ください。

 

記事原文

 

前のページにもどる