Gene Construction Kit マニュアル
更新日: 14/03/14

チュートリアル 13:Deluxe Import 機能を使用した GenBank シーケンスファイルの読み込み

Deluxe Import を使えば、Gene Construction Kit で GenBank のあらゆる検索機能を実行できるのに加え、インターネットを通じてファイルを取り込み、それらを GCK に直接インポートすることができるようになります。GenBank のすべての feature は、ユーザーが独自にカスタマイズできる変換スキームを使って GCK の feature に1対1で変換することができます。以下のチュートリアルでは、これらの機能の基礎をご紹介します。画像は Macintosh と Windows のスクリーンショットを交互につかいます。いずれのプラットフォームでもプログラムは同じように動作します。

  1. まずはじめに、GenBank ファイルをインポートする際に使用するグラフィックのフォーマットをセットアップする必要があります。Tools > Deluxe Import > Conversion Defaults を選択します。GenBank の各種 feature (allele, attenuator, C_region, など) が GCK のグラフィック要素にどのようにマッピングされるかを示す Conversion Defaults パネルが表示されます。現在これらの設定は黒のフォントとラインを使ったシンプルなフォーマットになっています。

  2. チュートリアルを進めるにあたり、GenBank の feature をよりカラフルにするオプションを用意してあります。Tools > Deluxe Import > Restore Conversion Defaults を選択して、これらを見ることにしましょう。Open ダイアログが開きますので、GCK のメインフォルダに移動して、Importing Defaults という名称のファイルを選択し、Open ボタンをクリックします。Conversion Defaults ウィンドウは図 2.67 に示すようになるはずです。
    図 2.67: Deluxe Import で Conversion Defaults を読み込んだ例

    Use 列では、マウスをクリックすることでチェックマークと x マークを切り替えることができます。チェックの入った feature のみが GCK に転送されることになります。2列目の Name は GenBank の feature 名を、3列目の Type はその feature が GCK でどのように表示されるかを示します。各 feature がどのように処理されるかは、その feature を選択し、Feature メニューと Format メニューを使って GCK で表示される feature の外観を変更することによって変更することができます。選択した Conversion Defaults は、Tools > Deluxe Import から、保存 (Save) または元に戻す (Restore) ことができます。

  3. Tools > Deluxe Import > Open Sequences File を選択します。gbmam_sample.gbk という名称のチュートリアルファイルを開きます。画面は図 2.68 のようになるはずです。
    図 2.68: Deluxe Import で開いた Feature Mapping

  4. この図で、これから試す単一ファイルには5種類の遺伝子が存在する点に注目してください。これらの遺伝子は、ウィンドウの左側にある Entries リストに並んでいます。図では、最初のエントリー「BOVNEURXIA」が選択されています。2番目のリスト Features には、このエントリ固有の全 feature が表示されています。これらはすべて GenBank features table から読み込まれたものです。3番目の列 Source には、features 列で選択された項目に関連付けされた GenBank テキストが表示されています。ここに示すように何も選択されていない場合は、Source フィールドには GenBank のすべてのコメントが表示されます。実際に Features を幾つかクリックしてみて、どのような Feature にどのような Source テキストが関連付けられているかをご確認ください。

  5. Location Prefs… ボタンは、GenBank ファイルにおける各種位置標識をどのように GCK の位置に変換するかを定義することができます。Transfer Prefs… ボタンは、GCK に取り込むデータの転送方法を GCK に伝えることができます。実際にこれらのボタンをクリックして内容を確認してみても構いませんが、ここでは変更を加えないで進めることにします。Convert To GCK ボタンをクリックしてください。図 2.69 に示すウィンドウが表示されるはずです。
    図 2.69: Convert to GCK ウィンドウ

  6. このウィンドウでは、GenBank ファイルで特定された各種 feature と Format を確認できます。ここから GCK ファイルを作成するには、Save Construct ボタンをクリックします。図 2.70 に示すような新規コンストラクトが作成されます。
    図 2.70:インポートされたコンストラクト

    この図は、オリジナルの GenBank ファイルでインポートするよう選択された GenBank feature のすべてをあらわしています。feature のいずれかをクリックして、Construct > Get Info... を選択すると、その feature の内容を確認することができます。