Gene Construction Kit マニュアル
更新日: 14/03/14

8.3 Format メニュー

Format メニューには、Gene Construction Kit の各種ウィンドウにおける情報の見せ方を変更するのに必要なツールが用意されています。利用できる選択肢は多岐にわたるため、Format メニューの項目はすべて階層構造になっています。Format メニューのサブメニューにあるオプションを表示するには、表示させたいメニュー項目上にマウスカーソルを置くだけです。カーソルの位置にサブメニューが表示され、さらなる選択肢が表示されます。多数の選択肢に直観的にアクセスするには、これが最も合理的な方法です。つまり複雑さの段階的開示 (revealed complexity) という概念を具現化したものです。

Format メニューの項目のほとんどは、多数のウィンドウから利用できます。例えば、Font は、リストウィンドウを除くすべてのウィンドウで利用できます。Fill (塗潰し) は、コンストラクトウィンドウとイラストレーションウィンドウで利用できます。Symbol は、コンストラクトウィンドウでしか利用できません。また、Grouping は、コンストラクトウィンドウのシーケンスビューでしか利用することはできません。

 

  1. Fill
  2. Lines
    1. …Pick a Width
    2. …(predefined line thicknesses)
    3. …(predefined directions)
    4. …Size Arrowhead…
  3. Font
  4. Style
  5. Size
  6. Color
    1. …Pick a Color…
    2. …Add a Color…
    3. …Remove a Color…
    4. …(predefined colors)
    5. …(user defined colors)
  7. Symbol
  8. Site Markers
    1. …Manual Arrangement
    2. …Automatic Arrangement
    3. …Auto Arrangement Settings…
    4. …Show Site as Text
    5. …Show Site as Symbol
    6. …Show Name Only
    7. …Show Position Only
    8. …Show Name and Position
    9. …Set Position Delimiters…
    10. …Attach at Left
    11. …Attach at Center
    12. …Attach at Right
    13. …At Nearest Horizontal
    14. …Attach at Top
    15. …Attach at Middle
    16. …Attach at Bottom
    17. …At Nearest Vertical
  9. Regions
    1. …Move Region Outwards/Upwards
    2. …Move Region Inwards/Downwards
    3. …Show As Protein
    4. …Don’t Show As Protein
    5. …Show Region Names
    6. …Hide Region Names
    7. …Reset Region Name Positions
  10. Grouping
    1. …No Grouping
    2. …Group by Threes
    3. …Group By Tens
    4. …Insert Line Break
    5. …Remove Line Breaks
  11. Chronography
    1. …Start New Generation…
    2. …Discard Generations…
    3. …Get Info For Current Generation
    4. …Show Previous Generation
    5. …Show Next Generation
    6. …Show Most Recent Generation
    7. …Show Most Ancient Generation
    8. …(user defined generation names)
  12. Preferences
    1. …Default Construct
    2. …Default Gel
    3. …Default Illustration

 

Fill

Format > Format Fill サブメニューには、選択したオブジェクトの塗潰しに使用するパターンを定義するための機能が用意されています。図 8.9 に示すのは、塗潰しパターンの選択肢です。提示されるパターンのいずれかをマウスでクリックすると、選択オブジェクトがそのパターンで塗潰されます。これは、コンストラクトのグラフィックビューでセグメントのパターンを定義したり、イラストレーションウィンドウで楕円 (ellipses)、矩形 (rectangles)、角の丸い矩形 (round rectangles) を塗潰すパターンを定義するのに利用することができます。イラストレーションウィンドウまたはコンストラクトウィンドウでどのパターンも選択しなければ、そのオブジェクトは透明になります (オブジェクトの塗潰しパターンを無し (none) にすると、そのオブジェクトの下にある別のオブジェクトを表示させることができます) 。塗潰し (fill) と色 (color) と組み合わせることで、バラエティに富む効果を表現することができます。モノクロとカラーのモニターでコンストラクトを使用する場合は便利です。

図 8.9: Fill Patterns

 

Lines

図 8.10: Lines Menu

…Pick a Width

…(predefined line thicknesses)

…(predefined directions)

…Size Arrowhead…

Format > Lines サブメニューは、ラインや矢印 (ラインの特殊形態) の属性をコントロールする機能が用意されています。図 8.10 に示すように、Lines サブメニューは幾つかの部分に分かれています。このサブメニューは、イラストレーションウィンドウでラインが選択されている場合、または、コンストラクトウィンドウでセグメントや領域が選択されている場合に有効になります。あらかじめ定義されたラインの太さのいずれかをクリックすると、選択状態にあるラインの太さが選択した太さに変わります。サブメニューに用意されていないラインサイズについては、Format > Lines > Pick a Width… を選択して定義することができます。サブメニューの下の部分をクリックすると、矢印の矢を選択したラインのいずれかの向きまたは両方の向きに配置することができます。コンストラクトで翻訳領域をあらわすラインの方向を選択すると、タンパク質配列のコーディングの向きを指定することになります。左から右 (または時計回り) なら、タンパク質が (上) 鎖の 5' 末端から 3' 末端へコーディングされていることをあらわします。反対に、右から左 (反時計回り) なら、タンパク質が (下) 鎖の 3' 末端から 5' 末端へコーディングされていることをあらわします。矢印の矢のサイズと形状は、Format > Lines > Size Arrowhead… オプションを選択することによって調整することができます。図 8.11 に示すのがこれです。矢印の矢はその端を任意の位置にドラッグするか、矢印の矢の側面にしたい別な位置をマウス� �クリックすることによって変更することができます。ダイアログに表示される水平線の太さは、編集するラインの太さと同じになります。

図 8.11:矢印の矢のサイズ設定

 

Font

標準的な Format > Font > Show Fonts メニュー (command-T Mac or Ctrl-T Windows) には、お使いのシステムで利用可能な全てのフォントが一覧で表示されます。これは、他の多くのアプリケーションで動作する Font メニューと同様に機能します。Font サブメニューは (Style および Size と共に)、イラストレーションウィンドウやコンストラクトウィンドウ (グラフィックビューでもシーケンスビューでも) でテキストが選択されている場合はいつでも利用することが可能で、これによって選択されたテキストの表示法を変更することができます。ゲルウィンドウの表示中にこの属性を設定すると、凡例テキストとテーブルで表示されている場合ならダイジェストのテキストに変更内容が反映されます。このサブメニューとその他のサブメニューにおいては、メニュー選択に対応するコマンド (Mac) / コントロール (Windows) キーは、シフトキー ( ⇑ で表記) とコマンド/コントロールキーの組み合わせになります。従って、Shift-command-B / Shift-ctrl-B は、シフトキー、コマンド/コントロールキー、および B を同時に押すことを意味します。Gene Construction Kit では、キーボードに対応する通常メニューはコマンドキーと共に選択し、キーボードに対応するサブメニューはコマンドとシフトキーと共に選択します。

 

Style

Format > Style メニューには、Plain Text (⇑-command-P/⇑-ctrl-P)、Bold (⇑-command-B/⇑- ctrl-B)、Italic (⇑-command-I/⇑-ctrl-I)、Underline (⇑-command-U/⇑-ctrl-U)、Outline (⇑- command-O/⇑-ctrl-O)、Shadow (⇑-command-S/⇑-ctrl-S)、CondenseExtend といった他のプログラムにもあるような標準的なスタイルオプションが用意されています。イラストレーションウィンドウでテキストを編集する場合には、Left Justify (⇑-command-L/⇑-ctrl-L)、Center (⇑-command-C/⇑-ctrl-C)、Right Justify (⇑-command- R/⇑-ctrl-R) を利用できます。これ以外にも、GCK 固有のスタイルが幾つか用意されています。シーケンスビューでコンストラクトを操作する場合は、Case as TypedUpper CaseLower Case を利用できます。なお、これらのスタイルは Bold と似ています。文字の表示法は変更しますが、文字そのものには変更は加えません。このメニューの最後の2つの項目も、イラストレーションウィンドウのテキストに適用するものです。Erase Behind Text は、テキストの背景にあるオブジェクトをすべて覆い隠すものです。Draw Behind Text は、テキストの背景オブジェクトを図 8.12 に示すように描画させることができるものです。

図 8.12: Erase Behind Text

 

このメニューを使って、スタイルをコピーしたり、スタイルをペーストすることもできます。あるコンストラクトに他のコンストラクトにペーストしたい特定のスタイルがあれば、そのセグメントからスタイルをコピーし、別のセグメントを選択して、そのスタイルをペーストします。これに関しては、Tutorial 22: スタイルのコピー&ペースト で説明してあります。

 

 

Size

Format > Size サブメニューでは、現在選択状態にあるテキストのサイズを設定することができます。

 

Color

…Pick a Color…

…Add a Color…

…Remove a Color…

…(predefined colors)

…(user defined colors)

Format > Color サブメニューを使えば、選択したオブジェクトのカラーを定義することができます。Color サブメニューから目的の色を選択することで、システムがモノクロであっても、オブジェクトのカラーを定義することができます。Color メニューは、Add a Color… および Remove a Color… を選択してカスタマイズすることもできます。新たに追加するカラーは、カラーピッカー、すなわち、ウィンドウに表示された色のいずれかを選択することで定義できます。カラーは、コンストラクトウィンドウならテキスト、コンストラクトのセグメント、マークを付けた部位、領域、シンボルに、イラストレーションウィンドウならテキスト、ライン (矢印)、矩形、角の丸い矩形、楕円にそれぞれ適用できます。カラーを作成したり追加する場合、それに意味のある名称を割り当ててメニューに加えることで (翻訳やコーディングなど)、あらゆるコンストラクトやイラストレーション間で使用する色の一貫性を保つのが容易になります。

 

Symbol

Format > Symbol サブメニューを選択すると、図 8.13 に示すようなグラフィカルなサブメニューが表示されます。シンボルのいずれかを選択すると、コンストラクトウィンドウで現在選択しているマーク部位 (複数可) がこのメニューで選択したシンボルに置き換えられます。なお、選択された部位がその名称で表示されている場合もシンボルを選択することができます。ただし、あるシンボルをコンストラクトウィンドウでダブルクリックすると、それが異なる制限酵素であっても、同一のシンボルで表示されている部位であれば全て選択されることになるので、シンボルは注意して変更するようにしてください。同様に、名称で表示されている部位をダブルクリックしても、その名称が使われている全ての部位が選択されることになります。

図 8.13:シンボルメニュー

 

Site Markers

Format > Site Markers サブメニューには、サイトマーカーの表示に関する特性を指定するためのオプションが用意されています。サイトマーカーは通常、シンボルでもテキストでも表示させることができます。テキストで表示する場合は、マーカーの名称と切断部位の位置のいずれか一方または両方を選択的に表示させることができます。シーケンス表示であるかグラフィック表示であるかを問わず、このメニューにあるいずれの項目もコンストラクトの部位をどのようにマークするかを決めるのに使用します。

 

…Manual Arrangement

このオプションは、Automatic Arrangement と対になるものです。Format > Site Markers > Manual Arrangement を選択すると、選択されたサイトマーカーはいずれも、ウィンドウのサイズを変更したり "ズーム" しても、自動的には移動しなくなります。これは個々のサイトマーカーに固有の属性です。

 

…Automatic Arrangement

サイトマーカーのいずれかを選択状態にして Format > Site Markers > Automatic Arrangement を選択すると、そのマーカーは他のどのサイトマーカーとも重なり合わないように自動的に移動します。コンストラクトウィンドウのサイズを変更したり、ズームインまたはズームアウトすると、そこにある複数のサイトマーカーは互いに重なり合わないような位置に自動的に配置されます。この機能は、ポリクローニング領域など、DNA に沿って多数の部位が重なり合うような場所にとても役立ちます。なお、Automatic Arrangement は、サイトマーカーの属性であるという点にご注意ください。サイトマーカーのスタイルのようなものと考えて結構です。Manual Arrangement の選択、または、マウスでサイトマーカーをドラッグしない限り、この属性はサイトマーカーに残ります。

 

…Auto Arrangement Settings…

Format > Site Markers > Auto Arrange Settings… を使えば、環状コンストラクトにおけるサイトマーカーの整列法を定義することができます。環状コンストラクトのサイトマーカーを自動整列を使って表示する場合、図 8.14 に示すような2通りの方法で自動整列を実行できます。

図 8.14:自動整列スタイル

 

A はコンストラクトに沿って、B はウィンドウの境界線に沿って整列したものです。サイトマーカーの表示法は、図 8.15 に示すダイアログを使って選択します。Letting GCK Choose (ラジオボタンの最後) は、表示法の選択を状況に応じて GCK に判断させるものです。これは、特に拡大率を高くしてズームする場合に便利な選択肢です。この事例の場合、サイトマーカーを拡大表示するならコンストラクトに沿って整列させるのが良いですが、コンストラクト全体を表示するなら垂直に整列させるのが良いでしょう。なお、このメニューはコンストラクトが環状の場合のみ利用できる点にご注意ください。

図 8.15: Auto-Arrangement Settings ダイアログ

 

…Show Site as Text

…Show Site as Symbol

Format > Site Markers サブメニューに用意されたこれら2つの項目を使えば、選択された任意のマーク部位をシンボル表示またはテキスト表示のいずれかに選択することができます。これら2つのフォーマットはいつでも切り替えたり、その変更対象をひとつのサイトマーカーに限定することも可能です。

 

…Show Name Only

…Show Position Only

…Show Name and Position

Format > Site Markers > Show Name OnlyFormat > Site Markers > Show Position OnlyFormat > Site Markers > Show Name and Position を使えば、サイトマーカーをテキストで表示する場合、表示させるテキストの内容を指定することができます。位置情報は、Set Position Delimiters… で定義した方法でサイトマーカーラベルに表示されます。

 

…Set Position Delimiters…

Format > Site Markers > Set Position Delimiters… サブメニュー項目を使えば、インジケーターテキストの左側と右側に使用するキャラクタを設定できます。図 8.16 に示すダイアログボックスを使って、実際に表示される位置番号の左側と右側に配置したいテキストを入力します。この事例の場合、部位名の直後にスペースが入り、そのあとに左側の丸括弧、そして、位置番号の後に右側の丸括弧が続きます。サイトマーカーの表示はこの指定で “HindIII (29)” のようになるはずです。

図 8.16:Set Delimiters ダイアログ

 

…Attach at Left

…Attach at Center

…Attach at Right

…At Nearest Horizontal

これら4つの項目は、コンストラクトとサイトマーカー間に伸びるラインをサイトマーカーテキストの左右 (水平) 方向のどの位置に接続させるかを定義するものです。Format > Site Markers > Attach at Left を選択すると、サイトマーカーテキストの必ず左端にラインが接続されます。Format > Site Markers > Attach at Center を選択すると、サイトマーカーテキストの必ず水平方向中央にラインが接続されます。Format > Site Markers > Attach at Right を選択すると、サイトマーカーテキストの必ず右端にラインが接続されます。Format > Site Markers > At Nearest Horizontal を選択すると、ラインの接続に最適な位置を CGK に判断させます。この自動接続を選択すると、サイトマーカーを自由に移動してもマーカーテキストとラインの接続の見た目の美しさを常に保つことができます。

 

…Attach at Top

…Attach at Middle

…Attach at Bottom

…At Nearest Vertical

これら4つの項目は、コンストラクトとサイトマーカー間に伸びるラインをサイトマーカーテキストの上下 (垂直) 方向のどの位置に接続させるかを定義するものです。Format > Site Markers > Attach at Top を選択すると、サイトマーカーテキストの必ず上端にラインが接続されます。Format > Site Markers > Attach at Middle を選択すると、サイトマーカーテキストの必ず垂直方向中央にラインが接続されます。Format > Site Markers > Attach at Bottom を選択すると、サイトマーカーテキストの必ず下端にラインが接続されます。Format > Site Markers > At Nearest Vertical を選択すると、ラインの接続に最適な位置を CGK に判断させます。この自動接続を選択すると、サイトマーカーを自由に移動してもマーカーテキストとラインの接続の見た目の美しさを常に保つことができます。

 

Regions

…Move Region Outwards/Upwards

…Move Region Inwards/Downwards

Regions (領域) が完成したものの、それらの配置を後からやり直したい場合があります。これは、メニュー項目の Format > Regions > Move Region Outwards/ Upwards (⇑-command-+/⇑-ctrl-+) と Format > Regions > Move Region Inwards/Downwards (⇑-command--/⇑-ctrl--) を使って実行することができます。ある領域を選択状態にした後いずれかを選択すると、選択された領域を outermost/top または innermost/ bottom の位置に移動させることができます。

 

…Show As Protein

…Don’t Show As Protein

これら2つのメニューは、単一または複数の領域が選択されたときに利用できる項目です。コンストラクトのグラフィカルビューでは矢印しか描画されませんが、シーケンスビューで、 Format > Regions > Show As Protein を選択すると、その領域に対応する DNA を矢印の向きに翻訳された一連のアミノ酸として描画します。Format > Regions > Don’t Show As Protein を選択すると、翻訳された領域はグラフィックのプレーンな矢印に戻ります。

 

…Show Region Names

…Hide Region Names

ある領域を選択したあと Format > Regions > Show Region Names を選択すると、図 8.17 に示すように領域のグラフィックのそばに領域の名称が配置されます。このオプションは、コンストラクトをシーケンスビューで表示しているときは選択できません。なお、ある領域のグラフィックを選択すると、その名称も選択される点にご注意ください (その反対でも同じ)。これにより、領域の名称を色んな位置に移動しても、グラフィックに対応する名称を簡単に確認できるようになります。

図 8.17:領域の名称

 

…Reset Region Name Positions

Format > Regions > Reset Region Name Positions メニュー項目は、領域の名称をデフォルトの位置に戻し、領域に沿って並べます。

 

Grouping

Format > Grouping は、コンストラクトウィンドウがシーケンスビューになっているときだけ利用できるサブメニューです。DNA 配列の画面表示法 (および印刷結果) を詳細に定義することができます。Grouping は、スペースで中断されない互いに隣り合って配置するヌクレオチドの数を参照します。

 

…No Grouping

Format > Grouping > No Grouping (⇑-command-J/⇑-ctrl-J) は、ウィンドウ幅に基づいて塩基配列を折り返します。

 

…Group by Threes

Format > Grouping > Group by Threes (⇑-command-F/⇑-ctrl-F) は、翻訳されたアミノ酸配列の上にある DNA 配列を表示する場合に便利です。

 

…Group By Tens

Format > Grouping > Group By Tens (⇑-command-T/⇑-ctrl-T) は、長い塩基配列を一覧にするために便利なフォーマットです。塩基配列が 10文字ずつに区切られていれば、塩基配列の位置を目でたどり易くなります。

 

…Insert Line Break

…Remove Line Breaks

Format > Grouping > Insert Line Break は、挿入ポイントの直後の文字を強制的に改行します。塩基配列でセグメントを選択して Insert Line Break を選択すると、選択された塩基配列はそれ自身のフォーマット区画に配置されます。つまり、選択範囲の先頭で行が改められ、選択範囲の末尾が行末になるということです (次のフォーマット区画は次の行で開始します)。Format > Grouping > Remove Line Breaks は、選択した DNA セグメントから改行を削除します。セグメントを何も選択していなければ、すべての改行が削除されます。Grouping サブメニューを、Construct メニューの Display サブメニューと合わせて使えば、塩基配列のレイアウトを精密に定義することができます。

 

Chronography

Format > Chronography サブメニューには、コンストラクト合成過程のすべての手順をさかのぼり、コンストラクト情報の表示を変更することができる GCK のアーカイブ機能にアクセスする項目が用意されています。Chronography の使用法については、Tutorial 7:クロノグラフィ (クローニング履歴の再現) で既に説明してあります。

図 8.18: New Generation ダイアログ

 

…Start New Generation…

新しい "世代 (generation)" を定義することで、現在のコンストラクトの表示法を失うことなく、その表示法を好きな時に変えることができます。ある世代で定義される情報は、ラインの太さ、塗潰しパターン、カラー、および、コンストラクトのセグメントの特定の向き、マークの付いた部位、および、領域で構成されます (すなわち、コンストラクトの外観を決めるすべての要素)。Format > Chronography > Start New Generation (⇑-command-G/⇑-ctrl-G) オプションを使えば、新しい世代を定義できます。このオプションを選択すると、ダイアログボックスが表示され、これから定義する新しい世代に、現在の表示内容を保存 (または破棄) できます (図 8.18 参照)。チェックボックスにチェックを入れると、これから作成する新しい世代で表示されている情報を保存します。すべてのステップの履歴をたどりやすくしたり、コンストラクトの表示法を変更するために、各世代にはそれぞれの名称を付けることができます。また、世代ごとに任意のコメントを入力することもできます。コンストラクトの生成プロセスに関する情報を保存するのに便利な場所になります。

 

…Discard Generations…

Format > Chronography > Discard Generations を選択すると、不要になった単一または複数の世代を削除することができます。世代を削除することで、ファイルサイズを小さくすることができます。図 8.19 に示すのはそのダイアログです。複数の世代を削除するには、シフトキーを押したまま複数のリスト項目をマウスで選択します (シフト・クリック)。なお、この操作は元に戻すことはできませんのでご注意ください。一度世代を削除してしまうと、二度と回復させることはできません。

図 8.19:世代の削除例

 

…Get Info For Current Generation

各世代には、それに関する情報をそれぞれ保存することができます。この情報は世代を最初に作成するときに入力できますが、既に作成された世代の情報を編集するには、このメニューオプションを選択します。図 8.20 に示すダイアログが表示されます。

図 8.20: Generation Info ダイアログ

 

…Show Previous Generation

…Show Next Generation

Format > Chronography > Show Next Generation (⇑-command->/⇑-ctrl->) と Format > Chronography > Show Previous Generation (⇑-command-</⇑-ctrl-<) は、一定の条件が満たされないと選択できません (現在よりも新しい世代、または古い世代がある場合)。選択したコンストラクトの範囲に1世代以上からなるセグメントが含まれていれば、図 8.21 に示す警告ボックスが表示されます ("現在の選択範囲に次の世代が存在しないセグメントがあります。それでも、表示可能な次の世代を表示しますか?")。一般に、Gene Construction Kit で要求された内容を示すことができない場合は、図 8.21 に示すような警告ボックスが表示されます。

図 8.21:あいまいな世代

 

…Show Most Recent Generation

Format > Chronography > Show Most Recent Generation (⇑-command-A/⇑-ctrl-A) を選択すると、選択した各セグメントの最新の世代が表示されます。

 

…Show Most Ancient Generation

Format > Chronography > Show Most Ancient Generation (⇑-command-Z/⇑-ctrl-Z) を選択すると、選択したコンストラクトのセグメントについて存在する最も古い世代に対応する世代が表示されます。

 

…(user defined generation names)

既に定義してある世代の名称がこのメニューの一番最後にそれぞれ表示されます。このメニューから世代の名称を選択することで、その世代を表示させることができます。

 

Preferences

Preferences サブメニューを使えば、GCK で新規ウィンドウを作成する際に使用するデフォルトの値を設定できます。

Preferences サブメニューから開くことができるのは、Construct、Illustration、Gel ウィンドウです。任意のウィンドウのデフォルトの特性を設定するには、設定したい属性を通常ウィンドウで定義するだけです。例えば、 Construct preferences ウィンドウでデフォルトのセグメントカラーを定義するにはセグメントをダブルクリックして選択し、変更したいデフォルトカラーを Format > Color サブメニューで選択します。マーク部位のフォントを変更したい場合は、サイトマーカーを選択して、変更したいデフォルトのフォントを Format メニューの Font サブメニューから選択します。

 

…Default Construct

コンストラクトウィンドウでは、以下に示すデフォルトの属性を設定することができます。グラフィック表示に関する属性は、margins, linear or circular construct, segment thickness, segment fill pattern, segment color, segment direction (arrowheads), display site as text or symbol, auto-arrange or manual arrange placement of site markers, site marker font, site marker font size, site marker font style, site marker font color, site marker text justification, site marker symbol, site marker color です。シーケンス表示に関する属性は、grouping, line spacing, show/hide positions, font size, style, color です。

 

…Default Gel

ゲルウィンドウでは、以下に示すデフォルトの属性を設定することができます。margins, legend/ table font, legend/table font style, legend/table font size, threshold value, および、表示させるアイテムの選択 (legend, runoff count, size standards)。

 

…Default Illustration

イラストレーションウィンドウでは、以下に示すデフォルトの属性を設定することができます。object color, object fill pattern, object line thickness, line color, line thickness, line direction (arrowheads), text font, text size, text style, text justification, text color。