Gene Construction Kit マニュアル
更新日: 14/03/14

チュートリアル 7:クロノグラフィ (クローニング履歴の再現)

GCK のもっとも便利な機能の一つにクロノグラフィ (chronography) という機能があります。この機能を使えば、ひとつのファイルにある同じ塩基配列を異なる表示法でそれぞれ記憶できるのはもちろん、コンストラクトの更新履歴をさかのぼることができます。画面上に表示されるグラフィックは異なっていても、コンストラクト・ファイルに含まれる塩基配列はただ1つしか存在しないという点を理解しておくことが重要です。クロノグラフィを使えば、同一の塩基配列の重要な特徴 (feature) を様々な表現法で引き出すことができます。

  1. GCK を起動し、tutorial files フォルダにある pBR322 という名称のファイルを開きます。図 2.29 のようなコンストラクトが表示されるはずです。これは、幾つかの制限酵素部位にマークを付けたコンストラクトを極めて標準的な方法で表現したものです。ここで、SalI 部位にマーカーの名称と位置情報の両方が表示されている点に注目してください。これは、Format > Site Markers メニューを使って設定することができます。ウィンドウの右下には図の尺度をあらわすスケールマーカーが表示されています。スケールマーカーは、Construct > Display > Show/Hide Sites を使って表示と非表示を切り替えることができます。
    図 2.29: pBR322 のグラフィック表示例

  2. Construct > Display > Display Sequence を選択して図 2.30 に示す画面を表示させます。ご覧のとおり、クロノグラフィはコンストラクトのグラフィック表示はもちろん、塩基配列そのものの表記法を記憶させるのにも利用することができます。この表記は、塩基配列を10個毎にグループ化し、幾つかの部位にマークを付けて構成した単純なものです。
    図 2.30: pBR322 のテキスト表記

  3. Construct > Display > Display Graphics を選択して、図 2.29 のようにグラフィカルビューに戻します。クロノグラフィーのすべての機能は、Format > Chronography 以下のメニューからアクセスすることができます。コンストラクトの各表示は、異なる世代 (Generation) で呼ばれます。Chronography メニューの下には3つの名称 (restrictions sites, regions of interest, DNA sources) の世代がある点に注意してください。これらは、pBR322 コンストラクトに存在する3種類の世代です。メニューでチェックされているのが現在表示されている世代です。Format > Chronography > Show Previous Generation を選択してください。図 2.31 のような画面になるはずです。これは、過去の世代の一つで、これを generation#1 と呼ぶことにします (最も直近の世代は generation#0 と呼びます)。この世代では、複製起点 (origin of replication) と共にコーディング領域が表示されます。
    図 2.31: pBR322 Generation#1

  4. Construct > Display > Display Sequence を選択します。図 2.33 のように表示されるはずです。ここでは塩基配列が3つ毎にグループ化され、テトラサイクリン耐性遺伝子 (tetracycline resistance gene) の翻訳が表示されている点に注目してください。これは塩基配列が異なっているのではありません。異なっているのはその表示法のみです。
    図 2.33: pBR322 Generation#1 のシーケンス表示

  5. Construct > Display > Display Graphics を選択して、もう一度 Format > Chronography > Show Previous Generation を選択します。このコンストラクトの最も古い世代が表示されます。結果は図 2.32 のようになります。この世代はオリジナルの pBR322 プラスミドのコンストラクトで使用した3種類のセグメントを示しています。
    図 2.32: pBR322 Generation#2

  6. 12時と5時の間にある青色のセグメントをダブルクリックして、そのセグメントを選択状態にします。次に、Construct > Get Info… を選択します (または、command-I (Mac) /ctrl-I (Windows))。 コンストラクト内の各 DNA セグメントのソースに関する情報が表示されます。このように各 DNA セグメントのソースを丁寧に記載してゆくことで、コンストラクト全体の履歴を簡単に管理することができます。記入されたすべてのコメントは、GCK のファイル検索機能を使って検索することができます (詳細はチュートリアル8:コメントの検索とファイルの検索 をご覧ください。)。Cancel ボタンをクリックして、グラフィカルウィンドウに戻ります。Edit > Select All を選択して (または command-A (Mac)/ ctrl-A (Windows))、コンストラクトの DNA 全体を選択状態にします。
    図 2.34:DNA セグメントの情報

  7. Format > Chronography > Restriction Sites を選択して、このコンストラクトの最新の世代をもう一度呼び出します。ここでもう一度、このチュートリアルを通して見てきたのは全く同一の塩基配列であって、その表示法のみが異なるに過ぎないことを思い出してください。

  8. File > Open を選択し、tutorial files フォルダにある actin DNA という名称のファイルを開きます。SalI 断片をダブルクリックして選択状態にしたら (図 2.35)、Edit > Copy を選択してコピーします。ここでコピーしたフラグメントを pBR322 にクローニングします。
    図 2.35: Actin DNA の SalI 断片

  9. pBR322 ウィンドウを1回クリックしてアクティブにしたら、挿入ポイントを pBR322 DNA の SalI 部位に設置します。この操作は、DNA の SalI マーカー位置をクリックするか、SalI マーカー自体をクリックすることで実行できます。挿入ポイントが正しく設置されたら、Edit > Paste を選択して actin DNA の SalI 断片を pBR322 の SalI 部位にペーストします。ここで、ある領域を削除しようとしている旨の警告が表示されます。確認することはできませんが generation#1 のテトラサイクリン領域がここにあります。OK をクリックすると、図 2.36 のような結果になります。SalI マーカーの位置が更新され、また、ウィンドウ中央に表示されるコンストラクト自体のサイズも更新される点に注意してください。
    図 2.36: pBR322 に挿入された Actin 断片

  10. Edit > Select All を選択して、コンストラクト全体を選択状態にしたら、Format > Chronography > Show Previous Generation を選択して、前の世代を表示します。結果は図 2.37 のようになります。ここに表示されている内容は、actin 断片をコピーした際に一緒にコピーされた actin DNA の前の世代のものです。DNA 断片の世代は、その断片のコピーと共にすべてコピーされます。これにより、あるコンストラクトを構成する際に DNA の異なる部分がどこに由来するものであるか、その全ての経過を簡単にたどることができるようになります。コメントがセグメント毎にそれぞれ記入されていれば、それぞれの世代から判断してコンストラクト全体の履歴がどうなっているかを必要があればいつでも確認することができます。
    図 2.37:pBR322 に挿入された Generation#1 の Actin 断片

  11. もう一度、Format > Chronography > Show Previous Generation を選択します。図 2.38 のような画面になるはずです。actin 断片が単純なグレーのラインになっている点に注目してください。これは、actin DNA で指定された世代がそれ以前に存在しないために生じる現象です。actin 断片の開始部分の DNA を1回クリックして、コンストラクト全体の選択状態を解除します。
    図 2.38: pBR322 に挿入された Actin 断片 Generation#1

  12. Construct > Display > Display Sequence を選択して、コンストラクトを generation#2 のシーケンスで表示します。actin 断片のグレー表記が塩基配列表示においても継承されている点に注目してください。異なる世代を使用して異なるグラフィック表示方法を保持するのと同じように、異なる塩基配列表記を保持することができます。

  13. ある世代から次の世代に一度に1世代しか移動できないことで、複雑なコンストラクションプロジェクトにおいては、世代が何層にも蓄積することもあるので、移動するのが困難になるのではないかと思われる方がいるかもしれません。GCK では、Format > Chronography > 以下のメニューを使用して任意の世代にジャンプすることができます。すべての世代がこのメニューの下に一覧で用意されることになります。Regions of Interest 世代を選択すると、Regions of Interest 世代に移動することができます。

  14. この世代がどのような書式になるかを確認してください。ここで画面をグラフィカルビューに切り替えましょう (Construct > Display > Display Graphics)。セグメントのいずれかを選択し、その世代をいろいろと変更してみます。異なるセグメントの異なる世代を同時に表示させることができる点に注目してください。これによって、塩基配列およびグラフィックの表示方法を思い通りに操作できるようになるのです。

以上でこのチュートリアルは終了です。ここで作成したコンストラクトはもう使用しませんので、開いているすべてのファイルを保存せずにここで閉じてください。