Gene Construction Kit マニュアル
更新日: 14/03/14

8.1 File メニュー

File メニューでおこなうのは、データの読み込みとディスクやプリンタへの書き出し、あるいは、Gene Construction Kit® で使用するファイルの指定です。新規ウィンドウやファイルの作成、ファイルの保存、ファイルのインポートやエクスポート、印刷、および、GCK で使用するファイルの指定に関する様々なオプションが用意されています。

  1. New…
  2. Open…
  3. Import…
  4. Close
  5. Save
  6. Save As…
  7. Export…
  8. Revert to Saved
  9. Set Print Options...
  10. Page Setup…
  11. Print…
  12. Choose GCK Data Folder…
  13. Quit

 

New…

File > New… (command-N/ctrl-N) では、表示されるダイアログボックスの Document Type: ポップアップメニュー (図 8.1) で指定された内容に応じて空のウィンドウが作成されます。作成されるウィンドウは、Construct、Illustration、List、Gel、AutoFeature のいずれかです。ウィンドウタイプを指定したら、作成するウィンドウの名称を入力します。なお、この操作でウィンドウがその名称でドキュメントとしてディスクには保存されるわけではなく、ウィンドウを識別するための名称が与えられるに過ぎないという点に注意してください。あとで File メニューから Save を選択したとき、ファイルの保存にこの "New" ダイアログボックスで割り当てた名称が使用されることになります。このダイアログのボタンをマウスを使って選択するかわりに、対応するコマンドキーをショートカットとして利用することができます。Construct なら command-C/ ctrl-C、Illustration なら command-I/ctrl-I、List なら command-L/ctrl-L、Gel なら command-G/ctrl-G という具合です。

図 8.1: New GCK Document ダイアログ

 

AutoFeature ファイルは、普段利用する塩基配列をその特徴 (feature) に関するスタイルやコメントと共に保管するためのファイルです。Construct > Features > Mark AutoFeatures... を選択すれば、任意のコンストラクトに対して AutoFeatures に登録された全ての特徴についてマークを付けることができます。これについては、Tutorial 21: AutoFeature の適用図 7.1: 領域 (Region) をあらわす AutoFeature ウィンドウ で詳しく説明してあります。

 

Open…

File > Open… (command-O/ctrl-O) を選択すると、図 8.2 に示すように、これから開くファイルを選択することができます。このウィンドウの一番下にポップアップメニューがありますが、これは、このメニューで選択したタイプ別にスクロール可能領域に表示させるファイルを限定するものです。この事例の場合は、コンストラクトファイル (Construct File) のみが表示されています。ショートカットとして New ダイアログボックスと同じコマンドキーを利用できます。またこれ以外に、All Types には command-A/ctrl-A が割り当てられています。Open を選択すると、リストで選択したファイルを開くための処理が進み、新規ウィンドウにそのファイルの内容が表示されます。Cancel をクリックするとこのダイアログボックスが閉じられます。ファイルを開くと、新規ウィンドウが表示され、そのタイトルバーには選択したファイルの名称が表示されています。ウィンドウのタイトルバーには、ファイルの種類も表示されます。このプログラムで開いたウィンドウは、ディスク上の特定のファイルと、それぞれ、直接結びついています。ディスク上の任意のファイルについて、複数のウィンドウを開くことはできませんし、現在開いているいずれのウィンドウも複数のファイルにすることはできません。

図 8.2:Open ダイアログ

 

Import…

File > Import… (command-G/ctrl-G) については、既に塩基配列のインポート、および、Tutorial 12: 塩基配列およびその他の情報のインポートとエクスポートで詳細は説明してあります。図 8.3 に示すのはそのダイアログボックスです。Import ボタンを押すと、異なるファイル形式から Gene Construction Kit に DNA 配列がインポートされます。テキスト形式を除くすべての形式のファイルをインポートすると、オリジナルファイルに関連付けられたコメントも一緒に読み込まれます。テキスト形式のファイルをインポートすると、そのファイルの内容が単純に1文字ずつ読み込まれ、GCK のコンストラクトの塩基配列に正規の DNA 文字が配置されます。Staden 形式を除くすべての形式から読み込まれる文字は、正規の DNA 文字だけが読み込まれるようにフィルタが掛けられます ( “Legal Nucleotide Characters” 参照)。塩基配列にある U はすべて T に変換されます。DNA Inspector™ と Gene Inspector® ファイルは Textco の他のプログラムで使用される特殊な形式のファイルで、テキストファイルではありません。その他の8つのファイル形式は、テキストデータのみで構成されるものです。これら8つのファイル形式は、各ファイルにおける情報の編纂のされ方が異なるだけです。いずれも、定評のあるファイル形式で、異なるプログラム間で情報をやりとりするのに使用されます。ワープロソフトを使って独自のファイルを作成し、GCK に読み込んで使いたい場合は、テキストのみからなるファイルとして保存するよ� ��注意してください。テキストのみで保存しないと、図 8.3 に示すようなリストには表示されません。

図 8.3:塩基配列のインポート例

 

リストに表示されないファイル形式のインポート

GCK のコンストラクトファイルには、塩基配列情報のほかに GCK で塩基配列にある種の操作を加えた結果を表示できるようにするための情報が含まれています。コンストラクトファイルに含まれるこのような情報は、プログラミング上の要請に従って厳密に構成されています。Textco がプログラムに新しい機能を追加した場合は、それに合わせて、ファイル形式にも変更を加えなければならない場合があります。同様の必要性に迫られると、ソフトウェア開発者なら誰もが内部的なファイル形式に定期的な変更を加えますので、GCK 以外のプログラムに特有なファイル形式を GCK のインポート機能でサポートするのは、不可能ではありませんが、困難なものになります。しかし、ほとんど全てのプログラムは、塩基配列をテキストファイルとしてエクスポートすることができます。また、一部のプログラムには、GCG や GenBank のようなその他の標準ファイル形式でエクスポートできるものあります。このような形式を選べば、GCK に読み込めるファイルとしてエクスポートができるようになります。また、こうする以外にも、他のプログラムから塩基配列をコピーして、それを GCK にペーストする方法もあります。

 

Close

File > Close (command-W/ctrl-W) を選択すると、現在アクティブな (最前面の) ウィンドウを閉じることができます。前回 Save (保存) した内容に変更が加えられている場合は、図 8.4 に示すようなダイアログボックスが表示されます。Yes ボタンを選択すると、変更内容が保存されウィンドウが閉じます。No ボタンを選択すると、前回保存した内容に加えた変更を保存せずにウィンドウが閉じます。Cancel を選択すると、Close を選択する前の画面に戻ります。

図 8.4:変更内容を保存しますか?

 

Save

File > Save (command-S/ctrl-S) を選択すると、現在アクティブなウィンドウに加えたすべての変更内容を保存することができます。Revert To Saved メニューを選択して、これから保存するウィドウの状態を元の状態に戻すこともできます。

 

Save As…

File > Save As… を選択すると、図 8.5 のダイアログが表示されます。File > Export… で行うようなファイル形式の選択肢はありません。保存されるファイルはすべて Gene Construction Kit 形式となります。このオプションでは、ウィンドウを作成するときに使用したオリジナルファイルと同じタイプ (Construct, Gel, List, Illustration) の新規ファイルが作成されます。オリジナルファイルそのものには変更が加えられることなく、ウィンドウのタイトルが新しい名称に変更されます。このウィンドウで行われる編集はこれ以降すべて、新しい名称のファイルに対して行われることになります。編集するファイルの名称とウィンドウのタイトルは必ず同じになります。

図 8.5: Save As… (名前を付けて保存)

 

Export…

File > Export… では、現在アクティブになっているウィンドウのタイプに応じて異なるオプションが表示されます。このトピックの一部は、Tutorial 12: 塩基配列およびその他の情報のインポートとエクスポートデータのエクスポート で既に説明してあります。標準の Gene Construction Kit 形式に加えて、様々な出力形式を選ぶことができます。エクスポートするファイルは、JPEG ファイルに加え、それ以外の幾つかの標準的なファイルタイプで保存することができます。エクスポートされたファイルは、ほとんどの画像描画プログラムで開くことが可能で、Gene Construction Kit で作成した画像をそこで編集することができます。なお、エクスポートされたファイル形式は、オブジェクトの集合体として他のプログラムで編集することはできませんのでご注意ください (サイトマーカーを移動させたり、塩基配列情報を開いたりすること等はできません) 。こうしたオブジェクトに対する操作は、GCK でしかできません。DNA の塩基配列やゲル断片の一覧テーブルがなど、現在アクティブなウィンドウにテキスト情報が含まれていれば、そのコピーをテキストファイルとして作成することができます。

コンストラクトをグラフィックで表示させていれば、図 3.41:グラフィックコンストラクトのエクスポート例 が表示されるはずです。コンストラクトをグラフィックではなくシーケンスとして表示させていれば、図 3.42:塩基配列コンストラクトのエクスポート例 に示すダイアログボックスが表示されます。このダイアログの保存オプションのひとつに、コンストラクトのグラフィック表示のダイアログボックスにはない Formatted Listing as TEXT File があります。このオプションは、コンストラクトウィンドウの塩基配列リストとその他のテキスト情報を、現在ウィンドウに表示されているとおりの内容でテキストファイルとして作成するものです。塩基配列以外の情報には、DNA 配列 (および、ある場合はアミノ酸配列) の行番号 (位置情報) とマークを付けた部位の名称が含まれます。グルーピングも保持されます。関心領域をあらわす矢印や、ライン境界をあらわす点線などのグラフィカル情報は含まれません。ワードプロセッサにインポートし、あとから手書きで書き込む場合に便利なオプションです。

最後の選択肢は、Comments as TEXT File です。このオプションは、コンストラクトに関連するすべてのコメントを保存するために用意されている機能です。コンストラクトの中には様々なソースを由来とする DNA の操作を何ステップも経て成り立っているものもあります。あるコンストラクトにマーク部位、関心領域、DNA セグメントに関連付けられたコメントがそれぞれあり、そのコンストラクト自体にも幾層にもわたる世代があれば、このコンストラクトの履歴の全体像を把握するのは困難になります。このオプションは、コンストラクト内の全オブジェクトの全世代に関連付けられたコメントをテキストファイルとして作成するものです。出力されるコメントは、世代の新しいものから古いもの、および、複製起点 (線状コンストラクトでは 5' 末端) からの距離によって並べられられます。このテキストファイルは、標準的なワードプロセッサソフトで開いて、印刷したり表示することができます。出力ファイルの詳細なフォーマットに関しては、 “コメントの出力形式” をご覧ください。

最後に、GenBank ファイルとして塩基配列をエクスポートすることができます。これについては、Tutorial 23: GenBank 形式での出力で説明しています。このファイル形式は、複数のアプリケーション間で情報をやり取りするための共通形式として利用されるものです。お持ちの GCK ファイルを GCK を持っていない仲間と共有する手段として、この出力オプションを選択することができます。

 

イラストレーションのエクスポート

イラストレーションウィンドウからのエクスポートでは、コンストラクトウィンドウで説明したのと同様の選択肢が表示されます。File > Export… を選択すると、図 3.41 と同様のダイアログボックスが表示されますが、選択できるのは JPEG と PCIT のみである点が異なります。

 

ゲルのエクスポート

ゲルウィンドウからのエクスポートでは、同様の選択肢 JPEG, TEXT, PICT が表示されます。テキスト形式を選択すると、ゲルウィンドウをテーブル表示したときに表示されるのと同じような切断部位と断片サイズの全リストが保存されます (断片サイズテーブルの表示参照) 。

 

リストのエクスポート

リストウィンドウからのエクスポートでは、既に説明した内容と同じ選択肢が表示されます。File > Export… を選択すると、図 3.41 と同様のダイアログボックスが表示されますが、選択できるのは ListTEXT のみである点が異なります。

 

Revert to Saved

File > Revert to Saved を選択すると、現在開いているウィンドウで、最後に保存された時点から現在までに加えられた変更内容がすべて破棄されます。何らかの変更が加えられていれば、図 8.4 に示すようなダイアログボックスが表示されます。Cancel をクリックすると、プログラムを Revert to Saved オプションを選択した時点の状態に戻します。OK をクリックすると、最後に保存された時点以降に加えられたすべての変更内容が破棄され、ウィンドウを最後に保存された時点 (または、何も保存していなければファイルを開いた時点) の状態に戻します。

 

Set Print Options...

このメニューを選択すると、様々な印刷オプションを設定できるダイアログが開きます。マージン値の設定では、プリンタを利用できる最大領域と現在のウィンドウで利用可能な空間の境界との間の余白の総量を定義することができます。この値にゼロが設定されたら、プリンタで使用される最大領域を GCK ウィンドウで使用できることになります。ヘッダチェックボックスの Print document name は、ページの最上部に現在のドキュメントの名称を常に印刷します。Print page numbers は、印刷する際に各ページに番号が付けられます。最後の2つのオプションは、複数ページの塩基配列ドキュメントをプリントアウトする際に重要になるものです。

 

Page Setup…

File > Page Setup… は、適切な書式印刷を支援するために設計された標準ダイアログボックスです。Page Setup… およびその他のダイアログに関する詳しい情報は、お持ちのプリンタとコンピュータのマニュアルをご覧ください。なお、ダイアログボックス内のレイアウトは使用するプリンタによって異なる点にご注意ください。

 

Print…

File > Print (command-P/ctrl-P) を選択すると、現在アクティブなウィンドウの内容を印刷できます。コンストラクト、ゲル、および、イラストレーションウィンドウでは、画像サイズが1ページを超えるサイズになる可能性がある点に注意してください。このことは、印刷を開始する前に Edit > Show Page Breaks で確認することができます。「改ページ」ラインが何も表示されていなければ、その画像は1ページ内に収まることになります。なお、コンストラクトウィンドウでは、Construct > Magnification > Fit to Page を使って画像を1ページにフィットさせることもできます。

 

Choose GCK Data Folder…

GCK Data フォルダは、GCK がある種のタスクを実行するために使用するデータを保存する場所です。例えば、制限酵素リストやコドン表が保存されるのはこのフォルダです。GCK Data フォルダは、GCK をはじめてインストールする際に GCK アプリケーションと同じフォルダに配置されます。GCK では、この場所に GCK Data フォルダがあるのが前提とされます。何らかの理由があって、GCK アプリケーションや GCK Data フォルダを別の場所に移動したい場合は、GCK に変更後の GCK Data フォルダの場所を伝えることができます。File > Choose GCK Data Folder… を選択すると、図 8.6 に示すダイアログが表示されます。ダイアログには、現在の GCK Data フォルダの場所が表示されています。Cancel をクリックすると何も変更を加えずダイアログを閉じることができます。

図 8.6:現在設定されている GCK Data フォルダ

 

Change をクリックすると、図 8.7 に示すダイアログが開きます。標準ボタンとポップアップメニューを使って、GCK Data フォルダとして割り当てたいフォルダにカーソルを移動します。

 

図 8.7:GCK Data フォルダの選択例

 

Quit

File > Quit (command-Q/ctrl-Q) を選択すると、全てのウィンドウが閉じたあと、Gene Construction Kit が終了します。前回保存した内容に変更が加えられたウィンドウがあれば、変更内容を保存するか、破棄するかを選択するオプションが表示されます (図 8.4 参照)。