Gene Construction Kit マニュアル
更新日: 14/03/14

8.2 Edit メニュー

  1. Undo
  2. Cut
  3. Copy
  4. Paste
  5. Clear
  6. Special Paste…
  7. Select All
  8. Show/Hide Clipboard
  9. Find
  10. Show Overview
  11. Show Selection
  12. Show/Hide Page Breaks
  13. Set Gel/Construct Margins…

 

Undo

Edit > Undo (command-Z/ctrl-Z) は、他のアプリケーションでご存じかも知れませんが、ウィンドウを直前に行った作業の前の状態に戻すことができます。直前に行った作業とは、カット、ペースト、入力後のマウスクリックなどの操作です。

 

Cut

選択したアイテムをドキュメントから削除し、その内容をクリップボードに配置します。

 

Copy

選択したアイテムのコピー (複製) を作成し、その内容をクリップボードに配置します。

 

Paste

Edit > Cut (command-X/ctrl-X)、Edit > Copy (command-C/ctrl-C)、および、Edit > Paste (command- V/ctrl-V) は、他のアプリケーションと同様に機能します。Cut は、選択したアイテムをウィンドウから削除し、その内容を一時保管領域、すなわちクリップボードに配置します。Copy は、Cut に似ていますが、選択したアイテムの内容をクリップボードに配置するだけで、これによって削除されるものは何もありません。Paste は、クリップボードにあるものなら何でも現在のカーソル位置に貼り付けます。Gene Construction Kit では、オブジェクトのカット、コピー、ペーストを実行する場合に特殊な状況が関連することがあります。

まずはじめに、コンストラクトでセグメントを選択する場合、それは DNA の二重鎖であることを忘れないでください。セグメントの選択法と、セグメント末端の定義によって、このセグメントの末端が平滑末端 (blunt ends) か突出末端 (staggered ends) に変わります。あるセグメントをダブルクリックすると、グラフィカルビューであっても、シーケンスビューであっても、その最も近傍にある2つの境界 (borders) にはさまれたセグメントが選択されます。マークされた部位が何もなければ、同じスタイルが設定された塩基配列全体が選択状態になります。シーケンスビューでダブルクリックすると、フォント、カラー、スタイル、サイズ等に変更がない限り、マークの付いた部位にはさまれた DNA セグメントが選択されます。フォント、カラー、スタイル、サイズ等に変更があれば選択はその地点で停止します。この機能によって、グラフィカルビューでは表示させたくない保存配列 (conserved sequence) のような DNA セグメントをシーケンスビューで定義して表示させることができます。塩基配列の特性に関する詳細なプレゼンテーション用イラストレーションを、コンストラクトのグラフィカルビューを維持しながら効率的に作成することができます。コンストラクトの世代ごとに塩基配列表示のフォーマットを変えることもできます。

特別な処理が行われる状況が一つあります。図 8.8 に示す状況で発生するものです。この特殊なケースでは、2つの制限酵素の認識部位が互いに隣り合い、切断部位が重なり合っています。このセグメントをダブルクリックで選択するか、上鎖の切断1から切断2までをドラッグすると、上鎖は選択状態になりますが、下鎖はどこも選択状態になりません。それでも選択した塩基配列 (上鎖) のフォントとカラーをあえて変更しようとしても、下鎖は一切反映されません。また、このセグメントに対してあえてコピーやカットを実行しようとしても、GCK はそれをさせてはくれず、警告ボックスでこの操作は不可能であることが表示されます。1番目の制限酵素で切断を行うと、2番目の制限酵素認識部位はその時点でなくなってしまうので、この状況は、生物学的には起こりえないものだからです。

図 8.8:制限酵素部位が重なり合った例

 

DNA セグメントを他のコンストラクトや同一コンストラクトの他の部位にペーストする場合、ペーストする対象の断片の部位とそのセグメントの末端が適合するか否かが検査されます。もし適合しない場合は、図 3.22 に示すライゲーション・ダイアログボックスが表示され、ライゲーションが可能になるように末端位置を調整するかを質問されます。このことは実験室で行う作業と同じです。クリップボードに環状コンストラクトのセグメントをコピーし、それを新規コンストラクトウィンドウにペーストするとコピーした内容が線状コンストラクトで表現されます (これもまた、実験室で行う実験と同じです)。しかし、同じ環状コンストラクトのセグメントをイラストレーションウィンドウにペーストした場合は、それはイラストレーションの一部として GCK に判断され、コピーされた状態と同じ円弧で描画されます。

Gene Construction Kit は、情報をクリップボードに格納する方法もスマートです。画像データとテキストデータの両方が保存されるのです。適正に動作するアプリケーション (Apple や Microsoft のガイドラインに沿ったアプリケーションなど) なら、クリップボードからそのうちの必要な情報を利用することができます。グラフィックビューで表示されたコンストラクトからセグメントをコピーし、それをテキストエディタ等にペーストすると、DNA 配列情報がペーストされることになります。反対に、クリップボードの同じ情報を使って、それを画像処理アプリケーションにペーストすると、そこには選択したセグメントの塩基配列ではなく、画像がペーストされることになります。画像とテキストのいずれも表示できるプログラムの場合には、GCK オブジェクトをクリップボードから情報を受け取ると、それをどのように取り扱うかが判断されます。

コンストラクトウィンドウのマークの付けられた部位をコピー&ペーストする特殊なケースでは、そのウィンドウがゲルウィンドウかイラストレーションウィンドウかで処理が異なります。コンストラクトウィンドウのマークの付いた部位を選択し、それをゲルウィンドウにペーストした場合、GCK はそれを制限酵素のダイジェストを実行するものと見なし、その制限酵素による DNA の消化で得られた結果をあらわす断片をレーンをゲル上に作成します。コンストラクトウィンドウでマーク部位のコピーを選択し、その内容をイラストレーションウィンドウにペーストした場合は、GCK はそれを凡例を作成するものとみなします。これら2つのペースト機能で、ゲルを作成することとイラストレーションウィンドウでコンストラクト凡例を作成する作業が容易になります。

 

Clear

Edit > Clear を選択すると、選択されているものはいずれも削除されます。これによってクリップボードの内容が置き換えられることはありません。Clear は Undo (元に戻す) には対応していません。

 

Special Paste…

Edit > Special Paste (command-U/ctrl-U) は、すでに説明してありますが (図 3.23 付近を参照)、断片のペーストに際して特別な処理がなされます。これを選択すると、図 3.23 に示すダイアログが表示されます。ペースト処理の前に断片を反転すると、セグメントの向きがターゲット部位にペーストする際に逆になります。フラグメントの反転のほかにも、全フラグメントに対する Trim EndsFill Ends オプションも用意されています (前者は S1 ヌクレアーゼ処理、後者はポリメラーゼの埋め合わせに相当)。Leave Ends Alone オプションを選択すると、末端に対する特別な処理は何も行われません。適合しない末端があれば、ライゲーション・ダイアログボックスが表示されます。

 

Select All

Edit > Select All (command-A/ctrl-A) を選択すると、現在選択しているタイプのアイテムがすべて選択状態になります (例えば、マーク部位を選択しているときに Select All を選択するなら、マーク部位のすべてが選択状態になります)。コンストラクトウィンドウで何も選択せずに Select All を選択すれば、コンストラクト全体が選択状態になります。ゲルウィンドウで Select All を選択すれば、ゲルレーンのすべてが選択状態になります。イラストレーションウィンドウで Select All を選択すれば、イラストレーション内のすべてのオブジェクトが選択状態になります。

 

Show/Hide Clipboard

Edit > Show/Hide Clipboard を選択すると、クリップボードの内容をあらわすウィンドウを表示または非表示にすることができます。GCK と他のアプリケーション間で情報をやりとりする際に問題が発生した場合、クリップボードの内容を調べることで、何らかの手がかりを得られる場合があります。

 

Find

Edit > Find を選択すると、コンストラクト内の塩基配列を検索するための選択肢が用意されたサブメニューが表示されます。クエリー配列との厳密な一致による検索か、クエリー配列との不完全な一致による検索のいずれかを選択できます。ミスマッチを許容する場合、クエリー配列の中からミスマッチを許容する塩基 (小文字で記入されたクエリだけがミスマッチを許容) と厳密に一致する塩基 (大文字なら完全一致) を指定することができます。これは、塩基配列における転写因子結合部位などを検索するのに役立ちます。例えば、TGASTCA ('S' は G または C をあらわす) なら AP-1 が認識され、TTGGCnnnnnGCCAA ('n' は任意の文字) なら NF-1 が認識され、TGAstca なら Swi6 が認識されます。このような事例の場合、クエリーで小文字で入力された箇所の文字だけがミスマッチを許容します。swi6 の場合、先頭の3文字は厳密な一致ですが、最後の4文字部分に 1-2 のミスマッチがあっても転写因子は結合します。これに関する詳細は、Tutorial 20:Find Sequence をご覧ください。

塩基配列のクエリーの入力が完了し検索を開始したら、Edit > Find > Find Next (または command-G/control-G) を使用して、クエリーモチーフの次のインスタンスを検索することができます。DNA セグメントが選択状態にあり、その塩基配列が別の箇所にもあるかどうかを調べたいときは、Edit > Find > Find Selection を選択して確かめることができます。

クエリー配列に塩基配列を使用したことがあれば、GCK で開いている他のコンストラクトファイルに対する検索にもその配列を使用することができます。コンストラクトファイルの別ウィンドウをクリックし、Edit > Find > Find Next (または command-G/Control- G) を選択するだけです。

 

Show Overview

Edit > Show Overview は、ウィンドウ全体の内容を画面にあわせて縮小するオプションで、コンストラクトウィンドウとイラストレーションウィンドウから利用することができます。これを選択すると、カーソルの形状が小さな拡大鏡に変わります。縮尺表示されたウィンドウの特定の場所を拡大鏡でクリックすると、画像が通常サイズに戻り、クリックした位置が画面の中央になるように表示されます。この機能を使えば、規模の大きいイラストレーションでも画面上を移動しやすくなります。

 

Show Selection

Edit > Show Selection は、リストウィンドウ以外のすべてのウィンドウで利用できるオプションです。選択状態の任意のオブジェクトを表示させることができます。あるコンストラクトの塩基配列がシーケンスビューで選択状態になっているけれども、配列内の別の場所がスクロールされていて見えなくなっている場合に役に立ちます。Show Selection を選択することで、選択状態の塩基配列を表示できるようになります。

 

Show/Hide Page Breaks

Edit > Show/Hide Page Breaks は、全てのウィンドウで機能するオプションです。画面上に1ページの四隅をあらわすラインが表示されます。コンストラクトウィンドウとイラストレーションウィンドウで特に役に立ちます。コンストラクトをシーケンスビューで表示している場合は、自動的に改行 (Page break) が表示されます。

 

Set Gel/Construct Margins…

Edit > Set Gel/Construct Margins… は、ゲルウィンドウとコンストラクトウィンドウ、および、イラストレーション内のゲルおよびコンストラクトにおいて、上、左、下、右側のマージンを定義するものです。

注意:マウスを右クリックすると、一般的な Edit (編集) メニュー操作も利用することができます。