HOME > テクニカルサポート > 製品 一覧 > Gene Construction Kit > チュートリアル
ヒューリンクステクニカルサポート
Gene Construction Kit マニュアル ホームページ | GeneConstructionKit
更新日: 14/03/14

チュートリアル 5:コンストラクト表示の修正

Gene Construction Kit には、作成したコンストラクトに注釈を加えたり、重要な特徴にマーカー (標識) を付ける手段が多数用意されています。

  1. GCK を起動し、前のチュートリアルで保存した construct#4 ファイルを開きます。このファイルがない場合は、Tutorials フォルダに用意されている construct#4 を使って始めることもできます。

  2. 塩基配列の表示は、Format メニューに用意されている様々なアイテムを使用して変更することができます。ヌクレオチド 10-33 をマウスでドラッグして AT が多く含まれる (=開裂しやすい) セグメントを選択します。次に、Format > Font > Times を選択します。Times は等幅フォントではありませんが、GCK ではそれぞれの文字がラインに沿って同一の幅になるよう、文字の間隔が均等に割り振られる点に注目してください。次に、Format > Style > Bold を選択します。ボールドの文字は、ボールドでない文字に比べて幅が広いので、この塩基配列の分だけ横にはみ出てしまいます。この場合は、文字間の幅を狭める Format > Style > Condense を選択して調整することができます。このように、任意の DNA セグメントの色、フォント、スタイルを変更し、そこに何らかの特徴があることを示すことができます。メニューから自由に選んでこのセグメントのフォーマットを試してみてください。

  3. 何らかの特徴 (feature) をあらわす方法はもう一つあります。それはフレーム (Frame) を使用することです。フレームがどのように表示されるかを説明しましょう。ヌクレオチド 676-699 を選択してください (多クローニング領域にあります)。Construct > Features > Make Frame を選択します。これにより、選択した DNA セグメントの周囲にフレームが作成されます。この領域 (アミノ酸配列) およびサイトマーカーもこの枠内に含まれます。結果は、図 2.19 のようになります。フレームを選択すると (選択状態にすると)、その DNA セグメントに関連する全ての情報が一つにまとめられます。

    図 2.19:フレームを付けた塩基配列

  4. フレームの外観は、通常のやり方と同じく、Format メニューのアイテムを使用して変更することができます。なお、Format メニューで指定したアイテムの効果をフレームに適用させるためには、そのフレームが選択状態になっている必要があります (選択状態であればウィンドウでハイライト表示されます)。フレームを選択した状態で、Format > Lines を選択し、メニューから2番目に太いライン (幅 2px) を選択します。Format > Color > Yellow を選択したら、塗潰しパターンを Format > Fill で指定します。パターンや色を変えてどのような外観になるか実際にお試しください (なお、塩基配列を印刷する場合、テキストが見にくくならないよう塗潰しパターンは色を薄めを指定するようにしてください) 。

  5. フレームの枠内にはサイトマーカー、DNA、領域が取り囲まれている点に注目してください。Construct > Features > Set Frame Contents… を選択することで、フレームの枠内に含める内容を制限することができます。図 2.20 に示すように、このダイアログからフレームで囲む項目を定義します。以下と同じ内容をダイアログで設定して OK ボタンをクリックしてください。
    図 2.20: Set Frame Contents ダイアログ

  6. DNA 配列とタンパク質配列の表記の識別がやや困難に感じるようであれば、タンパク質配列の見た目を変更してみてください。タンパク質配列を1クリックして選択状態にしたら、Format > FontTimes を選択したあと、Format > StyleItalic を選択します。現在の画面は図 2.21 に示すようになっているはずです。このように配列を表示させるための実に様々な方法が用意されているので、配列が何であろうと任意の特徴をあらゆる表現手段をつかって表示することができます。
    図 2.21:フレーム付き配列の変更例

  7. Construct > Display > Display Graphics を選択します。複製起点 (origin of replication) として定義した新しい領域がグラフィカル表示にも表示され、また、シーケンス表示で選択した領域も選択状態で表示されている点に注目してください。これら2つのコンストラクト表示法の間には、直接的な対応関係があります。グラフィカルビューで加えた変更内容はシーケンスビューにもそのまま反映され、また、シーケンスビューで加えた変更内容もグラフィカルビューにそのまま反映されるのです。グラフィカルビューは、お持ちのコンストラクトの内容を分かり易く表示するだけですが、断片のクローニング (Tutorial 6: DNA セグメントのクローニングとサイレント突然変異) でインターフェースの使い易さを保つのに欠かすことのできない機能です。

  8. サイトマーカー名 BamHI をクリックしたあと、コマンド+A (Mac) / Ctrl-A (Windows) をクリックして (Edit > Select All を選択しても同じです) サイトマーカーすべてを選択状態にします。ここで、BamHI サイトを除くすべてのサイトマーカーの外観を変更したいとしましょう。この場合、他のサイトは選択したまま、BamHI の選択のみを解除する必要があります。これは、通常のやり方と同じように、シフトキーを押しながら BamHI サイトをクリックすることで実現できます (このプロセスはシフト・クリック "shift-clicking" と呼ばれる方法です)。BamHI サイトを除くすべてのサイトが選択されていることを確認します。次に、Format > Site Markers > Show Site As Symbol を選択してサイトをシンボルで表示します。結果は図 2.9C のようになるはずです。図に示すように、いずれのシンボルも同一のものはない点に注意してください。
    図 2.9C

  9. [GCK の Demo version をお使いの場合、ファイルを保存することはできません。次のチュートリアルに進む場合は、現在作成しているファイル construct#4 を開いたまま進んでください。ここで終了する場合は、ファイルの変更内容を保存せずに閉じることになります。]

  10. Trial Version または Full Version のアプリケーションをお使いの方は、File > Save As… を選択して、ファイル名を myconstruct#5 に変えて、自分でお使いのフォルダに保存してください。なお、他の人がこのサンプルファイルを使うかもしれませんので、あらかじめ用意されているチュートリアルファイルを上書きしないように注意してください。ここで保存したファイルは次のチュートリアルでも使用します。次のチュートリアルでは、外来 DNA の組み込み先としての新規ベクターの扱い方を説明します。

ここでチュートリアルを終わりにすることも、次の Tutorial 6: DNA セグメントのクローニングとサイレント突然変異 に進むこともできます。次に進む場合は、現在作成したファイル construct#5 を開いたままにしておきます。終わりにする場合は、このファイルを閉じてください。

 

注記:

  1. フレームは、フレーム上をオプション+クリック (Mac の場合) するか、Construct > Select Frame を選択して目的のフレームをクリックすることで選択状態にすることができます。マウス操作に長けている方は、フレーム内に含まれる DNA をトリプル・クリックしてそのフレームを選択状態にすることも可能です。

  2. 単一のサイトマーカーをクリックしたあと、シフトキーを押しながら BamHI サイト以外のすべてのサイトマーカーをクリックしていっても、同じ結果にすることができます。

 

記事原文

 

前のページにもどる