ヒューリンクステクニカルサポート
クイックスタートガイド TOP へ 掲載 - 05/08/01 カレイダグラフ製品ページ

一歩進んだ事例

ここからは、さらにカレイダグラフのすばらしさを紹介する事例を取り上げます。これまでに学んだ事例と違って、順番通りに学ぶ必要はありません。あなたが関心をもつ話題を選んで、そのすばらしさを体験してください。内容は次の通りです。

さらにこの後の「同型式のグラフの定義」では、グラフの統一性を保つ方法を学びます。


凡例の編集

ここでは、凡例のテキストと枠の編集の仕方を説明します。 凡例の枠は、ツールボックス下部の三つのアイコンで変えられます。中でも二つのセクションに分けられた一番下のスタイルアイコンが、特に大きな役割を果たします。これを使って、いろいろ変えてみましょう。

凡例: プロットの各変数を同一化するのに使用するシンボルやラベルを含むプロットの一部。
  • Examples フォルダ内 Plots フォルダにある Sample Plot ファイルを開いてください。


  • 凡例をクリックしてください。
  • ツールボックスから、スタイルアイコンのライン幅セクション(上下矢印)をクリックし、ポップアップメニューからヘアラインを選択してください。凡例の枠が、シャドウからヘアラインに変わりました。

  • スタイルアイコンのスタイルセクション(上下矢印の左側)をクリックし、ポップアップメニューから点線を選んでください。凡例を囲んでいる線が点線のパターンに変わりました。


  • 最後にライン幅ポップアップメニューからなしを選んでください。凡例の枠が取り払われました。

次に凡例のテキストを編集してみましょう。

  • ツールボックスのテキストツール ( ) を選択してください。選択ツールの右側にあります。アイコンをクリックしても、キーボードの T を押しても選択できます。
  • 凡例の中の三つのラベルのどれかをダブルクリックしてください。ダイアログが表れます。
  • このダイアログのテキストを削除し、何か好きなテキストを入力してください。フォント、サイズ、スタイルなど好きなように変えてください。
  • OK をクリックしてプロットに戻り、変更を確かめてください。

さて今おこなった変更は、一つのラベルのみの変更です。もしテキストツールの代わりに選択ツールを選べば、一度にすべての凡例の属性を変えることができます。ただし、選択ツールでテキストを変更することはできません。

関連:凡例の編集


数式入力の使い方

この事例では、データウィンドウの数式入力の使い方を学びます。マルチライン(複数行の)数式についても学びます。

数式入力ウィンドウは、データ分析の非常に強力なツールです。最前面のデータウィンドウでデータを入力したり変更する数式 (関数) を操作します。数式の結果は、データ列、セル、メモリに渡すことができます。

数式: 既存のデータからデータを生成する一連の値、コラム参照、メモリ参照、関数あるいは演算子。
数式入力: 最前面のデータウィンドウで機能する数式を入力したり、実行するのに使用するウィンドウ。
数式スクリプト: 数式入力ウィンドウの添付ノートに書かれたプログラム。 数式スクリプトはデータを開いたり、プロットを作成したり、プロットをディスクやプリンタに書き出す工程を自動化できます。
  • 数式では、メモリ番号と列番号を使うことができます。メモリ番号は 0 から 99 まで、使用する際には m を頭に付けます (例:m15、 m35 など)。
  • 列番号は c0 から c999 までです。(例:c10、c55 など)列番号は列の最上段に表示されます。(※v3.6 以前のバージョンでは、列ヘッダーに C の表記はありません。)データウィンドウで列の選択が行われたときは、選択された最初の列が 列番号 0 になることに注意してください。
  • 列番号を表示させるにはデータウィンドウの拡張ボタン をクリックします。

以下に例を示します。

c2=c0+c1; 最初の列と次の列を加算して、結果を列2 に代入しなさい。
c1=c0/1000; 列0 を 1000 で除算して、結果を列1 に代入しなさい。
c2=cos(c0); 列0 のコサインを求め、結果を列2 に代入しなさい。

数式を実際に実行して、どのようにデータウィンドウが変わるか見てみましょう。

  • ファイルメニューから新規作成を選んで、空のデータウィンドウを開いてください。
    数式入力で数式を実行するには、データウィンドウが必ず開かれていないといけません。そうしないと実行ボタンを押しても実行されません。
  • ウィンドウメニューから数式入力を選択してください。 デフォルトではファンクションキー F1 が選択済みになっています。F1 から F8 キーには、新たに定義した関数を登録することができますが、F1 はキーはいつでも使えるようにとっておいて、F2 からF8 キーを使うようにすることをお奨めします。
    • 注意: 以下のステップでは、実行をクリックする代わりに Enter (Windows) または Return (Macintosh) を使うことができます。
  • F2 をクリックして、c0=index() + 1 を入力し実行をクリックしてください。 列0 に1から100 までの値が入力されました。


  • F3 をクリックして、c1=log(c0) を入力し実行をクリックしてください。 列0 の対数が計算され、列1 に入力されました。
  • F4 をクリックして、c2=c1^2 を入力し実行をクリックしてください。 列1 の値を2 乗して、結果が列2 に入力されました。
  • F5 をクリックして、cell(0,3)=csum(c2) を入力し実行をクリックしてください。 列2 の値の総計が計算され、結果が第3 列第0 行のセルに入力されました。右側にウィンドウをスクロールして確かめてください。


    • カレイダグラフでは上記のように、数式を一つ一つ入力して実行しなければならないという決まりはありません。マルチライン(複数行の)数式で、一度に複数の数式を実行することができます。

F1 キーの左に添付ノートボタン ( ) があります。このボタンを押すとエディタが表れます。この数式の編集ウィンドウに複数行の数式を記述し、一度に実行させることができます。数式は、各行に別々に書かれ、最後にセミコロンを付けてください。添付ノートウィンドウを使って、先の数式を実行してみましょう。

添付ノート: データおよび数式入力ウィンドウの両方で利用できるテキストエディタ。データウィンドウでは、現在のデータセットに関する情報を入力するために使用されます。数式入力では、複数行の数式やプロット工程を自動化するスクリプトを書くために利用できます。
  • ファイルメニューから新規作成を選んで、空のデータウィンドウを開いてください。
  • ウィンドウメニューから数式入力を選択してください。
  • 添付ノートボタンを押して数式の編集ウィンドウを開いてください。このボタンはF1 キーの左にあります。
  • 以下の数式を入力してください。1行づつ、セミコロンを忘れずに記述してください。
    c0=index() + 1;
    c1=log(c0);
    c2=c1^2;
    cell(0,3)=csum(c2);


  • 数式の入力が終わったら、ファイルメニューから閉じるを選択して、数式入力ウィンドウに戻ってください。「実行をクリックすると・・数式添付ノート・・を実行します。」というメッセージが表れています。


  • 実行をクリックしてください。

これは大変便利な機能です。添付ノートで数式をテキストファイルとして保存できますので、必要なときに呼び出して再度実行することができます。


一元配置分散分析の実行

サンプルのデータファイルを使って一元配置分散分析を実行する手順を見て行きましょう。3つ以上の異なる群の平均がひとつの要因に影響を受けているかを見たい場合はこの検定を行ってください。この検定は、2つを超える群の比較ができる点を除いて対応のない t 検定と同じです。 結果の一部として、KaleidaGraph は F 値と P 値を計算します。

パラメトリック検定: 標本が正規分布する母集団から抽出されたという前提を持つ検定。パラメトリック検定の例として、t 検定分散分析があります。
ノンパラメトリック検定:データが正規分布しているという前提を持たない検定。値の順位について検定が行われます。ノンパラメトリック検定には、Wilcoxon 検定Kruskal-Wallis 検定Friedman 検定などがあります。
F 値 : この値は誤差平方平均に対する群の平方平均の比率です。値が 1.0 に近づくほど、群間に有意差がないと判断することができます。値が大きい時は、一つもしくはそれ以上の母集団から抽出されたと結論付けることができます。どの群が異なっているかを判断するには post hoc 検定を行います。
P 値 : 確率を示す値で、範囲は 0 ~ 1 です。分析する群間に統計的に有意な差があるかどうかを調べるために使用されます。この値が一定の水準 (通常は0.05) 未満であれば、群間に有意差があると結論付けられます。

保存されているデータセットを開いてこの例を開始しましょう。

  • ファイルメニューから開くを選択します。
  • Examples フォルダの中の Dataフォルダを開きます。
  • ANOVA data ファイルをダブルクリックして開きます。

このデータセットを使って一元配置分散分析を行います。

分散分析(ANOVA) : 2 つ以上の群の平均値を比較して、統計的に有意な差があるかどうかを調べる検定。 KaleidaGraph には、一元配置二元配置一元配置反復測定、および二元配置反復測定の 4種類の分散分析があります。
  • 機能メニューから 分散分析 (ANOVA) を選択して 分散分析 ダイアログを表示させます。
  • Sample 1 から Sample 5 までをリストから選択し追加ボタンをクリックして従属変数に割り当てます。変数を一つづつ割り当てることもできますし、5つを一時に選択して割り当てることも可能です。
  • 計算をクリックします。一元配置分散分析の結果が図 のように表示されます。今回の検定では P 値が 0.04325 となり、群間に有意差があることが分かります。

異なる群と差のサイズを知るには post hoc テストを実行してください。

Post Hoc テスト: Post Hoc テスト (多重比較とも呼ばれる) は、一元配置、または一元配置反復測定の分散分析を実行するときに、群間の差を調べるために使用されます。KaleidaGraph には、Tukey HSDBonferroniHolm、および Dunnett の Post Hoc テストがあります。
  • Post Hoc テストポップアップメニューから Tukey HSD を選択します。


  • 計算をクリックします。ANOVA の結果の下に post hoc テストの結果が表示されます。計算された P 値を比べると、他のサンプルに比べ Sample 4 が異なっていることが分かります。


  • 結果はこのダイアログでボタンを押すことによりクリップボードにコピーするか印刷することができます。
  • OK ボタンをクリックしてデータウィンドウに戻ります。

関連:「一元配置分散分析の実行


ユーザー定義の回帰曲線の適用

ここでは、ユーザー定義の回帰曲線の使い方を説明します。カレイダグラフの一般回帰曲線は、Levenberg-Marquardt アルゴリズムを使用しています。回帰曲線を当てはめるに際して、9 のパラメータを利用することができます。まず保存しているプロットを開くことから始めましょう。

  • ファイルメニューから開くを選びます。
  • Examples フォルダから Plots フォルダを開きます。
  • Inhibition Plot ファイルをダブルクリックします。


  • 一般回帰曲線を当てはめる準備が整いました。次のステップはデータにシグモイド回帰曲線を当てはめる方法を見て行きます。式は以下の通りです。
    y = a + (b - a) / (1 + x / c).

  • 回帰曲線メニューの一般サブメニューから fit1 を選択します。回帰曲線選択ダイアログが現れます。


  • 定義をクリックすると図 のような一般回帰曲線の定義ダイアログが現れます。


    フィールドに a+(b-a)/(1+x/c);a=1;b=100;c=1 を入力し OK を入力します。回帰曲線を定義した後に表示される情報は式の未知のパラメータの初期推測値です。


    • 注意: シンタックスエラーが返された場合は回帰曲線の式として m1+(m2-m1)/(1+m0/m3);m1=1;m2=100;m3=1 を使用してください。この式はライブラリに依存せず、常に有効です。

  • % Inhibition の前面にあるチェックボックスをクリックします。これはカレイダグラフに対し、この変数に回帰曲線を当てはめたいことを示唆します。


  • OK をクリックすると回帰曲線が計算されプロットに表示されます。


  • フィッティングの結果の表が現れます。
    • 自動的に表示されない場合は、プロットメニューの数式表示を有効にします。
  • 表には未知のパラメータの値が、標準誤差とともにリストされています。パラメータの値 +/- 標準誤差という具合に読みます。またカイ2 乗と R 値が、回帰分析の結果として表示されます。
  • 選択矢印を使って表を異なる位置に移動することができます。表を隠すには、プロットメニューで数式表示をオフにします。

最後のステップでは回帰曲線の線種と線の幅を変更します。

  • プロットから変数設定を選択します。



  • 回帰曲線設定タブをクリックします。回帰曲線の外観を変更することができます。


  • 適切なポップアップメニューを使って回帰曲線の線のスタイルや幅を選択します。
  • OK をクリックして変更を適用します。選択された幅によっては、画面上では違いが認識できないことがありますが、印刷すると差を確認することができます。

関連:「KaleidaGraph の回帰曲線


保存されたプロットのデータを編集

ここでは保存されたグラフのデータを変更し、プロットと回帰曲線を自動的にアップデートする方法を学びます。

始める前に、保存されたグラフを開いてデータを抽出する必要があります。

抽出ボタン: このボタン( ) はプロットウィンドウとレイアウトウィンドウの右上端にあります。プロットウィンドウでこのボタンをクリックすると、プロットが参照するデータウィンドウが表示されます。レイアウトウィンドウでこのボタンをクリックすると、現在のレイアウトに関連するプロットが表示されます。
  • ファイルメニューから開くを選択し、(Examples フォルダ内 Plots フォルダにある) Sample Plot ファイルを開きます。


  • プロットを最前面に出して、プロットメニューからデータ抽出を選択します。プロットの元となるデータが表示されます。


  • ウィンドウの名前は、元のデータファイルと同じ名前で始まります。さらに、再度保存されたとき区別できるように、日時が付け加えられます。データはプロットウィンドウにリンクされていますので、回帰曲線など何も変更はされていません。

それではデータを変更し、プロットをアップデートしてみましょう。

  • プロットメニューの自動リンクをチェックしてください。このコマンドがアクティブだと、データを変更するたびにプロットが自動的にアップデートされます。


  • 2 列目の最初の値 (78.5) を削除し、このセルに 100 を入力します。


  • 他のセルをクリックして自動リンク機能をアクティブにします。プロットと回帰曲線は、変更されたデータがただちに反映されます。
    • 複数のポイントを変更する場合は、プロットメニューのプロット更新を使った方が良いでしょう。自動リンクでは、データポイントを変更するたびにプロットを更新するからです。


      この例では、自動リンクを OFF にしてデータの変更をすべて終えるか、プロットの更新を選択、あるいはデータウィンドウの ボタンをクリックします。すべての変更が一度にプロットに反映されます。

関連:プロット作成例「保存されているプロット内のデータの修正


同型式のグラフの定義

よく同じようなグラフを作るなら、ほとんどの作業を自動化できるデフォルト設定、およびテンプレートが役に立つでしょう。カレイダグラフは、同型式のグラフを作るためのいくつかの機能が用意されています。 ここでは、スタイルファイルテンプレートプロットプロットスクリプトについて学びます。詳細についてはヘルプファイルの「付録」の「プロットの類型化」を参照下さい。

  • スタイルファイル :
    • フォント、プロット、色などを、あらかじめデフォルト(標準)として設定します。新しくグラフを作るときには、この設定が適用されます。必要に応じて設定が変えられるように、別々のスタイルファイルが保存できます。

  • テンプレートプロット :
    • プロット形式などを変えずに、作成済みのグラフのデータだけを置き換えたいときに役に立ちます。元のデータが回帰曲線やエラーバーを含んでいれば、新しく作られるプロットにも適用されます。プロットと軸タイトルはそのままオリジナルと変わりませんが、凡例は新しいデータの変数の名前を反映します。

  • プロットスクリプト :
    • 異なるデータのプロットを一度に作るときに役に立ちます。スクリプトで回帰曲線やエラーバーを指定すれば、各プロットはその通りプロットされます。また、自動的に保存したり印刷することや、タイトルや凡例をそれぞれに指定することもできます。

前のページへ戻る