ヒューリンクステクニカルサポート
Design-Expert サポート情報 Design-Expert 製品ページ
更新日: 21/01/13

5. 実験結果の分析

  1. モデルの効果の選択
  2. ANOVA と統計解析
  3. モデルの有効性の検証
  4. 主効果と交互作用の分析
  5. キューブプロットの描画
  6. 交互作用の等高線図と 3D プロットの作成
  7. 確認 (Confirmation)

 

計画の分析を開始するには、画面の左側にある “Filtration Rate” 応答ノードをクリックしてください。これをクリックすると、画面上部に分析ツールバーが表示されます。統計解析を実行するには、このボタンを左から右へ順番にクリックしていくだけです。

最初に選択されているのは、以下の図に示すように Transform ボタンです。Transform では、応答データに適用する数学関数のリストが提示されます。

変換オプションについて: それぞれの詳細な説明は Tips ボタンをクリックしてください。

 

Transformation のオプション

 

Transform 画面の下側には Design‐Expert による注記として、応答範囲が 2 倍(最大値と最小値の比率は 2.4186)を超えていることを示しています。この値は、べき変換での効果がわずかしか期待できない(“…power transforms have little effect.”)3 を下回っています。したがって、数学的変換はここではデフォルトの “None” のままにしておきましょう。後で説明する診断プロット(Box-Cox)では、トランスフォームが必要であればその旨が告知されます。

 

モデルの効果の選択

“Effects” タブをクリックしてください。画面には、全効果(正方形のプロット)の絶対値が半正規確率プロット上に表示されます。右側はパレート図です(詳細は後で説明します)。 効果の正負 Positive/Negative Effect は色分けにより判別できます。

効果の半正規プロット:選択なし

 

画面上に表示されたメッセージに注目してください:“Select significant terms – see Tips.”(有意項を選択してください - 詳しくは Tips をご覧ください)。ここで、どの効果をモデルに組み入れるかを選択する必要があります。この時点でモデルに組み込む効果を選択しないで先に進むと、“You have not selected any factors for the model.”(モデルで使用する因子が選択されていません)と始まる警告メッセージが表示されます。これを無視して先に進むこともできますが、その場合は(効果のない)モデルとしての意味しかもちません。それが嫌なら、Effects ビューに戻って指定しなおすこともできます(この方が遥かによい判断です!)。

効果の選択は、正方形のポイントをマウスでクリックするだけです。まず始めに、以下の図と同じように、プロットの右端にある最大の効果をクリックしてください。この際パレート図でも選択されます。

第一の効果を選択

 

デフォルトでは、最小効果の50%を意味する赤い “error line” が表示されます。このラインは、効果を選択する際の基準を視覚的に示す役目を果たします。重要でない効果は 0 付近のライン上に並ぶはずです。もし、このラインが小さい効果に合致しない場合は、このラインをクリックして最小効果(左側)のグループと揃うところにドラッグすることができます。

ラインから外れたすべての効果が選択されるまで右から左へ個々の効果を選択していってください。この例では、最後の効果は因子 C です。因子 C とゼロ付近に並ぶさらに小さい効果には大きな隔たりがあります。大抵の場合、この隔たりが効果の選択をやめる良い指標となります。

注意: スクリーンチップスボタン()をクリックすると、半正規プロットの詳細情報を参照して効果を選択することができます。

 

半正規確率プロット - 主要な効果を選択

ボックスをドラッグして、一度に複数のエフェクトを選択することもできます。

選択した効果の大きさを実際に確認するために、Design-Expertは、パレート図と呼ばれる順序付けられた棒グラフにそれらを表示します。縦軸は絶対効果のt値を示していることに注意してください。この無次元統計は、標準偏差の観点から効果をスケーリングします。この場合、グラフの外観に違いはありませんが、因子レベルの失敗やデータの欠落などが発生した場合、t値スケールは相対効果のより正確な測定値を提供します。次に大きいバーをクリックすると、以下に示すようにABDとして識別されます(右下)。

ABDを選択した効果のパレート図(間違っています!)

 

ABD バーは下限値よりも下にあることに注意してください。したがって ABD バーはクリックして除外します。

効果の統計的計算について: “Numeric” をクリックすると選択したモデルの効果と、それ以外の推定誤差の詳細を定量的に確認することができます。見やすくするには、上部にあるフルウィンドウアイコン のフルウィンドウをクリックします。この画面は “Auto select...” ボタンからモデルを選択しても表示することができます。とはいえ今のところ半正規プロットで選択されたモデルの説明を続けます。応答曲面計画にはAuto select のほうが便利です。詳細については、これらのチュートリアルを参照してください。
効果リスト

 

ANOVA と統計解析

さて、いよいよ分散分析(ANOVA)表をもちいて、統計の詳細をみてゆく段階となりました。“ANOVA” タブをクリックして、選択した効果とその係数を見てみましょう。Design‐Expert のデフォルトでは、青いテキストで注釈が表示されます。

注意: 注釈の表示/非表示は View で切り替えることができます。

Model の確率(p-value)を見てください。Design‐Expert のデフォルトでは、値が 0.05 以下であればそれを有意 significant と判断します。これは、“Edit” -> “Preferences” -> “Math Preferences” -> “Math Analysis”で変更できます。

モデル項 A、C、D、AC、AD に関する P-value についても調べてみると、いずれも 0.05 の判定基準を余裕で通過しています。

 

ANOVA レポート

 

文脈依存型のヘルプについて: ある数値を右クリックして “Help” を選択すると、ANOVA 表の数値に関する定義を表示させることができます。試しに平均二乗残差 (Mean Square Residual) の統計値についてこれを実行してみてください。以下の図のようになります。
文脈依存型 Help へのアクセス

 

R‐squared(R二乗)やその他の統計値を見たい場合は、ANOVA の出力結果の他のペインを確認してください。また、それぞれに付いた注釈を参照し、さらに詳しいことを知りたい場合は Help にアクセスしてください。そして、“Coefficients”タブを見て、モデル係数とそれに関連する統計の推定値を確認しましょう。最後に、コード化された表記とコード化されていない表記の両方の予測方程式について、“Coded Equation”タブと“Actual Equation”タブを確認しましょう。

数について論じるのはこれぐらいにして、次に進んで最終的に効果グラフに話をさせましょう。しかし、その前にモデルの有効性を検証する必要があります。

 

モデルの有効性の検証

“Diagnostics” タブをクリックして、残差の正規確率プロットを作成してください。

残差の正規確率プロット

 

デフォルトでは、残差はスチューデント化されます。これは原則として、標準偏差スケールに変換されます。また、外的に実行され、残差の計算の前にそれぞれの結果が除外されます。統計の専門家たちはこの手法を“case-deletion diagnostic” と呼びます。実験や測定でなにかが上手くいかずに特定の試行に実際の外れ値が生成される場合は、モデルのフィッティングに影響を与える前に矛盾する値が削除されます。これにより、あらゆる異常の検出力が向上します。

生の残差 (raw residuals) オプションについて: このような2水準完全実施要因計画の場合、生の残差を(元の測定単位で)プロットすることも同様に効果的です。以下のように Diagnostics Toolbar のプルダウンオプションで “Residuals”(raw)を選択して実際に確認してみてください(パターンに明らかな変化はありません)。
残差の様式の変更
最終的には、スチューデント化されたスケールに戻すことをお勧めします。一般的にはこれが残差を診断するもっとも堅牢な手法だからです。

 

残差の正規プロットは、直線に近づけば近づくほど異常性がないことをあらわします(データは完全に直線上にプロットされる必要はありません。これには、「太鉛筆検定」と呼ばれる有効な経験則があります。太めの鉛筆を直線上に置いて、データポイントがそれによってすべて隠れるようであれば、そのデータは十分に正規性があると判定するものです)。この事例のプロットをみると、特に問題ないようですので次に進むことにしましょう。

“Resid. vs. Pred.” を選択してください。以下のようなグラフが表示されます。

残差と応答予測値

 

残差のサイズは、その予測値とは無関係(independent)である必要があります。別の言葉で言い換えれば、スチューデント化された残差の縦方向の広がりは、予測された値の水準全域にわたってほぼ均一である必要があるということです。この事例のプロットをみると、特に問題はなさそうです。

次は “Resid. vs. Run.” を選択して「外れ値 t 」と呼ばれることが多い、とても便利なプロットを見てみます。特定の試行における標準偏差(t 値)が、他のすべての想定と比較して解離しているのはいくつかを表示できるためです。

Resid vs. Run プロット(試行順は無作為化されているため異なる場合があります)

 

Design‐Expert には、ランチャートの信頼区間 95% の管理限界とよく似た赤のラインが上下に表示されます。この事例では、突出した点は特にありません。なお、グラフは試行順を無作為化してプロットしているため、実際の画面では、ここに示したポイントの順番とは異なる場合があります。実際の画面では、外れ値だけでなくパターンを見るようにしてください。分かりやすい例は、最初から最後まで残差が着実に減少している、つまり、減少傾向であるということでしょう。これはシステムの安定性の問題を引き起こしますので、調査する価値は十分あります。ただし、実験を順不同で試行して、結果にバイアスをかける応答の傾向に対するプロテクトを取り入れます。

範囲から外れたポイントについて:外れ値がひとつでもあれば、それをクリックして、グラフの左側にそのポイントの座標を表示させることができます。プログラムはこのポイントを記憶し、他のプロットでもこのポイントの選択状態は保持されます。この機能を使えば疑わしいポイントなら何でも追跡できるため、特に残差の分析で役立ちます。この機能は、グラフの解釈にも利用できます。ぜひお試しください。このグラフ以外の任意の場所をクリックして、ポイントを非表示にしてください。

以下のように、ポイントを強調するオプションを使用しても有益でしょう。

このフラグを使用すると、デザインレイアウトや Design-Expert 内のあらゆる場所にさかのぼって追跡し続けることができます。試してみてください!

 

Box Cox プロットに進みましょう。これは、最適なべき乗則変換を計算するために考案されたものです(詳細は Montgomery 著 Design and Analysis of Experiments を参照してください)。画面の左側に推奨される数学的変換がテキストで表示されます。この事例の場合は “None” です。実際に知りたい情報はこれだけです!

Box-Coxの詳細について: この内容をもっと詳しく掘り下げたい人は、Box‐Cox 画面が解釈に役立つよう色分けされている点に注目してください。青のラインは、現在の変換を表します。この事例の場合、応答値に適用するべき乗を表す Lambda 値として青のラインは 1 を指し示しています。Lambda 値 1 は、変換の必要がないことを表しています。緑のラインは最適な Lambda 値を表しており、赤のラインはその値を囲む 95% 信頼区間を表しています。この 95% 信頼区間に 1 が含まれれば、推奨される変換はないことになります。以上をまとめると、次のようになります:青のラインが赤のラインの間にあれば、それは現在最適な領域に位置することを意味します。従って、応答の変換を変更する必要はありません。
べき乗変換を調べる Box Cox プロット
追記:Box Cox プロットは、ロジット(logit)と逆正弦平方根(arcsine square root)のどちらが適切な変換であるかを選択するのには役立ちません。詳細は、プログラムの Help システムに記述された “Response Transformations” をご覧ください。

 

戻って “Report” タブを選択します。ここで、診断統計の数値が個別にレポート表示されます。問題のある値にはフラグが立てられます。この例では、異常値として検出された値は特にありません。

診断レポート

 

主効果と交互作用の分析

残差分析で何の問題もなければ (この事例では明らかに問題はありませんでした) 、次に考察するのは有意な要因効果となります。

画面上部にある分析ツールバーから、“Model Graphs” タブを選択してください。交互作用 AC のプロットがデフォルトで表示されます(グラフに表示される X 軸がコード表記の単位になっていたら、“Display Options” -> “Process Factors” -> “Actual” を選択して、実測単位に戻しておいてください)。

因子A(温度)と因子C(濃度)の交互作用グラフ

 

このプロット(およびその他の効果プロット)に表示される “I型” のシンボルはプロットされたポイントの 95% 最小有意差(LSD)区間を示しています。

各ポイントの LSD 区間どうしが互いに重ならない場合(すなわち、仮想の水平線を左から右に引いた場合、LSD バーがその水平線と交差しない、または、重ならない場合)は、ポイントは大きく異なります。

 

一対比較するには: 一対比較を使用すると分離の検証を簡単に行うことができます。任意のモデル予測(例えば真ん中の LSDバーの左側にある三角形)をクリックすると一対比較が表示されます。
グラフに追加した一対比較。凡例はどの対が大きく異なるかを示されていることに注意してください
強調表示されたポイントの、平均の予測を通る横線が描かれます。この横線と重なるすべての縦棒は、選択したポイントから大きな差異がないと予測された平均値であることを意味します(例えば、グラフの右側に示された赤い三角形は予測値が A+, C+ であることを示しています) 。凡例には、どの中間点に有意差があるかも一覧表示されます。表示された一対比較が両側で行われた場合でも、表示されるのは区間の半分側のみとなります (分かりやすさが考慮されるため)。

グラフの右側にあるポイント(温度の高い部分)間の距離は、グラフの左側にあるポイント(温度の低い部分)の間にある距離よりも小さい点にも注目してください。つまり、ホルムアルデヒドの濃度(C)の効果は、温度(A)の高い水準においては有意性が小さいということです。従って、実験者は、ろ過速度を維持または増大させながら、高温の状態で有害なホルムアルデヒドの量を減らすことができることになります。この組み合わせは、交互作用プロットの右上にある黒い正方形の記号で表されます。

Factors Tool がデフォルトのプロットとともに一緒に開き、画面の右側に固定されます。必要があれば、上部の青の部分をクリックして、好きな位置にマウスをドラッグして移動してください。ツールをクリックして画面の右側にドラッグし、青い影が表示されたら放して、元の位置にロックすることができます。グラフ上にプロットさせたい因子(複数選択可能)を、このツールを使って制御できます。Factors Tool の下部にはプルダウンリストが用意されており、プロットする因子をここから選択することもできます。このリストにはモデルに取り込まれた項のみが含まれます。

交互作用に含まれる主効果の選択: Term リストの下矢印をクリックして、項 “A” を選択してください。Graphs Tool では、Interaction から One Factor に選択が移ることに注意してください。
主効果Aに変更(一因子プロット)
さらに重要な点は、A(Temperature)プロットの上部に警告が発せられることです。“Factor involved in an interaction.”(交互作用に関係する因子です)とあります。交互作用に関係する因子の主効果プロットからは、誤解を招く情報が発せられるため、これを根拠として実験の結論を導きだそうとしてはいけません。

 

それでは、この段階で執るべき意味のある作業に着手しましょう。Factors Tool に戻って Term リストから別の有意な交互作用 “AD” を選択してください。

交互作用 AD

 

Factors Tool 上において、軸(X1 または X2)をまだ割り当てていない因子には、縦の赤いスライドバーが表示されている点に注目してください。これを使って詳細な設定を選択できます。デフォルトのバーの位置は、軸のないこれらの因子の中間の水準にあります。

factor sliders の機能について:固定因子の水準はバーをマウスでドラッグするか、Factors Tool の下側にある数値領域内に変更したい水準を入力することで変更することができます。実際にこれを確認してみましょう。因子 C:Concentration のスライドバーをマウスで掴んで左端に移動してください。交互作用グラフに変化が起きますので注目してください。

因子Cのスライドバーを低水準(-)の左端に設定した交互作用ADのグラフ
撹拌速度が高いほど(因子 D を表す赤いライン)、非常に高いろ過速度を実現できることが、これで明らかになりました。この高い値のポイントをクリックすると、応答と因子の値に関する詳細情報を得られます。これが最適な結果です。
グラフをデフォルトの濃度 concentration にリセットしましょう。Factors Tool の下側に「3」と入力してください(この操作を有効にするには、因子 C をクリックして選択状態にする必要があります)。Default ボタンをクリックしても、オリジナルの設定に戻すことができます。実際にお試しください。しかし、ホルムアルデヒドの濃度を低くすることは製造工程の問題を解決するこの実験の第一の目標であることを忘れないでください。したがって、因子 C のスライドは必ず左側に戻しておいてください。

D:Stir Rate の横にあるボックスを右クリックして “X1 axis” に変更してください。交互作用 AD の軸が反転するのを確認できます。

軸の切り替え

統計的な違いはありませんが、これによって分かりやすくなったと思います。

テキストの変更について:最後にもう一つ付け加えます。マウスを右クリックすることで少なくとも殆どのグラフに表示されているテキストを編集することができます。例えば、交互作用グラフにおいては、X1 軸のラベルを右クリックします。
次に、“Edit Text” を選択することで、入力フィールドが表示されます。実際にお試しください!

 

キューブプロットの描画

Graphs Toolbar から “Cube” を選択してください。予測応答(predicted response)が3因子の関数として表示されます。これは有意な効果 A, C, D で作成されたものです。

 

このプロットは、3つの因子がどのように組み合わさって応答に影響を及ぼすのかを表すものです。表示されているすべての数値は予測された値ですので、作成されるプロットには実測値がなくても構いません。ここで関心のある因子は A、C、D ですので、プログラムはデフォルトでこれら選択します (Factors Tool にある任意の因子を右クリックすることによって、軸を変更することができます) 。

ろ過速度は、A+, D+, C‐ の設定で最大です (右下奥の隅で、予測応答は 100 を超えています) 。これは同時にホルムアルデヒド濃度を低減しようとする所期の目的とも合致します。すばらしい!!

 

交互作用の等高線図と 3D プロットの作成

交互作用は二次の非線形応答をあらわします。交互作用の等高線図と 3D ビューを実際に見てみると、この非線形性を視覚的に把握するのに役立つかもしれません。

まず初めに、“Contour” を選択して、等高線グラフを作成ください。二つの軸は、A(Temperature)と D(Stir Rate)になっているはずです。もしそうなっていなければ、Factor Tool を右クリックするだけで適切に変更することができます。

等高線グラフ

 

画面の色の濃淡を見て驚くユーザーがいるかもしれません - グラデーションは応答の低水準の値を表す青色から始まり、高水準の値を表す黄色で終わります。上記のグラフと同じように表示にするには concentration(C)を低いレベルに設定する必要があります。

フラグの追加/等高線の変更などについて: Design-Expert の等高線プロットは非常にインタラクティブです。例えば、等高線上をクリックするとそれが強調表示されます。これをドラッグすると、別の場所に移動することができます。さらに、グラフ内の任意の場所を右クリックするとオプションが表示され、フラグや等高線を追加したり、Graph preferences の項目を変更したりすることもできます。

 

次に、この実験から物事がどのように形成されるかを簡単に確認できる、印象的なグラフを作成するために “3D Surface” を選択してください。

交互作用 AC (フラグセット付) の 3D 表示

 

グラフ上にカーソルを移動してください。カーソルが手の形状 () に変わったら、左クリックして好きなように回転してみてください。

最終段階に進む前に、最初の交互作用を確認しておきましょう。Factors Toolbar にある Term リストから “AC” を選択します。D: Stir Rate 上のサイドバーを右(最高レベル)まで移動して、応答を増やします。

最初の交互作用ADの3Dプロット

 

一般的な実験計画で使用するための Design‐Expert に用意された便利なツールは、これでほとんど使い尽くしましたが、最後にもう一つだけ試しておきたいツールがあります。

 

確認 (Confirmation)

最後に検討する機能は、画面の左下にある Post Analysis ブランチに表示されています “Confirmation” ノードをクリックすると、プロセス因子のあらゆる設定条件に応答予測を作成することができます。次に、“Factors” タブをクリックします。この画面をはじめて立ち上げると、Factors Toolbar パレットにある各因子のポイントはいずれもデフォルトで中央に指定されています。この水準は赤のスライドバーを使って容易に調整することができます。より厳密に指定したい場合は、Sheet ビューで数値入力することも可能です。この事例では、分析結果から判断して以下のように各因子をそれぞれスライドさせることになります:

最適な因子の設定の確認

 

Design-Expert では実験結果から導かれるモデルを使用して、ユーザーがアクセスした時点の平均と試行数 (n) の区間 (PI) を予測します。これにより、ホルムアルデヒドの量を最小限にする、最小のろ過率が分かります。これで目的は達成しました。

Post Analysis の機能/その他: さらに確実性を向上させるにはサンプルサイズ (n) を増やすのが賢明です。予測区間 (PI) の改善という観点から、nが増加するにつれて応答は減少します。Confirmation タブで、n の値を変更して自分でこれを確認することができます。PI の変化に注目してください-限界値に近づいています。*実験的試行は6回くらいが妥当といえるでしょう。
以下のように、自分の確認試行にログインするための日付入力画面を作成することができます。それから、実結果の平均が計算されます。この値がPIの範囲内に入っている場合は、実験プログラムの次の段階に進むことができます。そうでない場合は注意が必要です。
判定結果の入力
*統計的詳細:無限試行の結果として、PI は信頼区間(CI)に向かって収束します。この信頼区間はオリジナルの実験における試行数(N)の関数です。Point Prediction ノードで CI を確認してください。信頼(1-α)でサンプリングされた母集団(P)に含まれるように、計算された許容区間(TI)も確認することができます。デフォルトでは母集団の標本の 99% が、許容区間内に 95% の信頼度で含まれるように設定されています。平均値の 95% で信頼区間は最も狭くなり、単一実測値(所定の Confirmation ノード)の 95% 予測区間でさらに広くなって、母集団の 99% を含む 95%(TI/許容区間)で最も広くなることに注意してください。最も厳密な区間 TI(許容区間)は製造仕様の設定で必要になることが多いですが、大抵の実験者はPI(予測区間)を予測値の管理方法として受けとめています。従って、Confirmation Tool は力強い見方となってくれるでしょう。

 

以上で、複数要因の分析に必要とされる重要な出力結果のすべてに目を通しました。作業内容を保存するために、ここで “File” -> “save” を実行するといいでしょう。ここで作成したモデルが Design‐Expert に保存されます。この出力結果は、必要があればいつでも簡単に再現できます。後から他のファイルと区別しておくために、ファイルに何かコメントを残しておきたい場合もあるでしょう。画面左側にあるツリー構造の左上にある Notes フォルダーノードをクリックして、ここにコメントを記入できることを忘れないで下さい。このファイルを後で開くときは、ここを見てコメントした内容を確認することになります。