ヒューリンクステクニカルサポート
Design-Expert サポート情報 Design-Expert 製品ページ
更新日: 21/01/13

3. 結果の分析

実験は無事、完了したものとしましょう。次に行う作業は、Design-Expert ソフトウェアに応答値を入力することです。ただし、チュートリアルの趣旨としては、全ての数値を入力したところで何ら得るものはありません。ここでは時間を節約するために、“Help” -> “Tutorial” へ移動し “Detergent” を選択して、応答データを読み込みましょう。次に、画面左の “Design” ノードをクリックします。これで画面には、下記に示すような応答データが表示されているはずです。

この事例では、何も入力作業はありませんが、通常は、この段階で相当な労力を費やすことになります。従って、応答データが全て入力されたら、保存することをお勧めします。

あらかじめ用意された応答データ

 

Design-Expert の Analysis ブランチに移動し、“Viscosity” ノードをクリックします。ウインドウの上部に配置されているタブを通じて、分析を進めることにしましょう。

分析の第一段階:Transformationオプション

 

まず始めに、この応答データに数学的変換(Transformation)を実行するかどうかを検討します。これにより、分析の統計的特性が改善されるケースもあるからです。例えば、応答の変動幅の大きさが数桁の違いで存在する場合は、対数(Log)スケールを使うと通常はうまく分析できます。この事例を見てみると、応答の最大値(Max)と最小値(min)の比率は、4 をわずかに上回るに過ぎません。この比率は、数学的変換が必要となるほど大きな値ではありませんので(画面下の注釈を参照)、選択肢はデフォルトで指定された None のままで結構です。また、coding for analysis(分析のコーディング)についても、pseudo のままで結構です。この指定により実際の成分の水準尺度が 0 - 1 に変更されるからです。

注意: 混合物のコーディングに関する包括的な解説につきましては、本チュートリアルのはじめに紹介した Cornell 著の参考書をご覧ください。それまでは、“Help” -> “Contents” を表示し、検索フィールドに「component scaling」と入力し Component Scaling in Mixture Designs をご覧ください。

 

次に、“Fit Summary” タブをクリックしてください。Design-Expert はここで、線形(linear)、2次(quadratic)、特殊3次(special cubic)、完全3次(full cubic)の各多項式を応答にあてはめます。

Fit summaryレポート

 

分析の開始にあたり、エイリアスに関する警告がないかを調べます。この事例の場合、完全3次モデル以降は、選択した計画(拡張した単体計画)で候補として選ばれることはありません。このことは、モデルの当てはめに選択したのは2次であったことを思い出せば、特に問題にすることはありません。

 ここで、Design-Expert が提示する最初のテーブルのモデルに注意してください。これは、以下内容を総括したものです。

 次に、“Sequential Model Sum of Squares” に移動します(場所はペインのレイアウトによって異なります)。

逐次モデル平方和テーブル

 

分析は基準となる平均応答から始まります。これは、応答に対して有意な効果をもたらす因子がない場合に、デフォルトで指定されるモデルです。出力結果には、追加する項の各組み合わせの有意性が順番に表示されます。プログラムが “Suggested” と示す水準より下では、p 値が有意ではなくなる(>0.05)ことに注意してください。そのため、これ以上項を追加しても利点はありません。

注意: 項目ごとの詳細を以下に示します。
  • “Linear vs Mean”:平均(Mean)の算出後、線形項を加えた有意性(3成分の合計が一定となる制約条件によって、線形混合モデルに関連する自由度は 2 しかないことがわかります)
  • “Quadratic vs Linear”:モデルに投入済みの線形項に2次項を加えた有意性
  • “Sp Cubic vs Quadratic”:2次項と線形項、および、特殊3次項の寄与
  • “Cubic vs Sp Cubic”:特殊3次項、2次項、線形項、および、完全3次項の寄与(この事例では、これらの項はエイリアス化されています)
  • etc...
各項の組み合わせについては、確率(“Prob > F”)を見て、それが 0.05(あるいは、任意に指定した統計的有意水準)を下回っているかどうかを確認するようにしてください。2次までは項の追加がこの特定モデルの改善に有意に働いていますが、特殊3次の水準までくると、それ以上の改善はもう見られません。プログラムは少なくとも1つの “Suggested” モデルを自動的に選び出し、それにアンダーラインを引きます。プログラムによるこの提案については、Fit Summary 下の全テーブルを検討して、必ずその裏付けを取るようにしてください。

次に “Lack of Fit” タブをクリックして、次のペインに移動しましょう。このテーブルの内容は、繰り返し測定の残差誤差(residual error)と純誤差(pure error)を比較するものです。もし、残差誤差が純誤差を上回る場合、その残差にはずれ(deviations)が存在することになりますので、より適切なモデルを使用して、それを取り除くことができる可能性があります。線形モデルの残差誤差は、不適合度(当てはまりの悪さ)が有意であることを示しますが、2次、特殊3次、完全3次においては、不適合度は有意ではありません(当てはまりは良い)。

Lack of fitテーブル

 

ここまでの時点で判断すると、統計的には2次モデルがとても良さそうです。

次に、“Model Summary Statistics” をクリックします。ここでは、モデル選択のためのいくつかの比較測定を見ることができます。

Summary Statistics

 

エイリアスされた3次モデルは除外するとして、標準偏差(“Std Dev”)の値が低く、R二乗(“R-Squared”)統計の値が高く、“PRESS” の値が低い2次モデルが最適となります。

次に進む前に、“File” -> “Print” を使って Fit Summary テーブルを印刷することをお勧めします。ここに表示されているテーブル、または、任意の選択範囲は、ワードプロセッサ、スプレッドシート、またはその他の Windows アプリケーションに切り取って貼り付けることができます。以上で、2次モデルを詳しく調べるための準備が整いました。

 

モデルの選択と分散分析(ANOVA)

画面上部にある “Model” タブをクリックして、Design-Expert で推奨されたモデルを見ていくことにしましょう。

モデルの選択

 

注意: ここで、スクリーンチップスボタン  を押すと、この段階で何ができるかについて、とても役立つ情報を見ることができます。プルダウンリストから、デフォルトで選択されたこの2次モデル以外のモデルを選択する場合もあります(稀なケースですが、Design-Expert が複数のモデルを推奨する場合があります。その場合は、これを必ず選択してください)。現在の画面では、統計的に有意でない項をマウスでクリックして除外する手動によるモデル削減モードになっています。例えばこの事例の場合、AB 項が統計的に有意でないということは、すぐにお分かりいただけると思います。
また、チップス画面に記述されているように、Design-Expert には、“Manual” の代わりに、Auto Select... ボタンからアクセスできるいくつかの自動削除アルゴリズムが用意されています。これを試してみたい場合は、ボタンをクリックしていずれかを選択してください。基本ルールに従って推奨される内容をポップアップで確認することができます。ただし、統計や懸案となっている事項の背景にある知識に基づいて、削減することに意味があると確証が持てない限り、混合モデルの削減はお薦めしません。これらについて学びたい場合は、ワークショップ(Mixture Design for Optimal Formulations)に参加ください。

 

“ANOVA” ボタンをクリックして、2次モデルの詳細を見てみましょう。

注釈表示を有効にしたANOVAレポート

 

統計結果は非常に良さそうです。

注意: このモデルの F 値は高く、確率値(Prob > F)は低くなっています。Design-Expert による注釈で示されているようにこの結果は良好です。この確率値は、各項の有意性を示しています。
P.S.混合モデルには intercept(切片)項が含まれていないため、主効果の係数(線形項)に応答全体の平均が組み入れられ、これらは一緒にまとめて検定されます。

次のレポート Fit Statistics に移動しましょう。

ANOVA 後の R 二乗と他の統計

 

ここに示される統計の内容は、既にその殆どは “Model Summary Statistics” テーブルでも見ていますが、いずれも問題無さそうです。適切な精度を判定する “Adeq Precision” の値は 27.943 となっており、要件を十分満たしている点に注目しましょう。

次に、この2次モデルに関する係数とそれに関連する信頼区間(onfidence intervals)を見てみましょう。

2次モデルに関する係数

 

注意: さらに続けて、成分のコード手法によってのみ変化するいくつかのモデルを確認してください。注釈を見ると、コーディングによっていかに異なるかを確認することができます。

 

引き続き ANOVA から次のタブ— “Diagnostics” を選択します。

 

モデルの統計的特性の診断

デフォルトで最初のペインに表示されるのは、残差の正規確率プロットです。

残差の正規確率プロット

 

データポイントは、ほぼ直線上に並ぶのが望ましいとされます。パターンが直線でない場合(S字曲線など)は、誤差項に正規性がないことを示します。そのような場合は、数学的変換によって修正できる可能性があります。このデータに関しては、問題となるような様子は見られません。

注意: 画面上部に Diagnostics Toolbar が表示されています。Studentized ボックスのチェックを外さない限り (これは推奨しませんが)、残差はスチューデント化される点にご注意ください。スチューデント化により、計画点の配置によるレバレッジの違いが少なくなります。例えば、中心点は、当てはめにおいて重みが殆どありませんので、レバレッジはそれだけ低くなります。残差を外部化すると、他と比べてそれぞれが際立ち、矛盾した結果がさらに目立つようになります。

 

診断を目的とする個別の詳細な統計グラフを確認するには、Report に移動します。

Report

 

推奨範囲を上回っている場合、青色(とアスタリスク)で警告表示される点に注目しましょう(Standard Order の 11 番の DFFIT 値)。Help で詳しく説明されているように、DFFIT は、ある応答が削除されたときに生じる各予測値の違いを測る指標です。警告の発せられた診断はこれ1つしかありませんでしたので、恐らく危険性の原因とはならないでしょう。しかし詳細に調べてみると、それが粘度応答の最も高い値のひとつであることが分かります(Actual Value = 130.00)。従って、実験者はこの応答の精度を再確認することをお勧めします。

 

モデルグラフの検討

残差の診断では、統計的問題はないことが分かりましたので、今度は、応答曲面プロットを作成することにしましょう。“Model Graphs” タブをクリックしてください。グラデーションのカラーシェーディングで色づけされた 2D 等高線プロットがデフォルトで表示されます。

応答曲面等高線プロット

 

Design-Expert には、設計空間に含まれる実際の点がすべて表示される点に注意しましょう。この事例で表示されているのは、混合物を構成する3成分の関数として表される粘度のプロットです。このスライスには、等高線プロットの中央に赤のドットで示されているように2つの重心と数字の “2” が含まれています。

注意: デフォルトのプロットには Factors Tool が一緒に表示されます。このフローティングツールは上部にある青の境界線をクリック&ドラッグすることで、必要に応じて好きな場所に移動できます。このツールは、グラフ上にプロットさせたい因子を選択するのに使います。リストには、現在グラフに表示されている因子を表す軸ラベルか、現在プロットされていない特定の設定を選択できるスライドバーが表示されます。この事例で取り扱う成分は3つしかありませんので、すべての成分が混合プロット(3成分ダイアグラム)上にあります。従って、スライドバーはここには表示されていません。それが表示されるとすれば、スライドバーはデフォルトで現在軸上に割り当てていない成分水準の中間点に指定されることになります。このスライドバーを左右にドラッグさせることで水準を自由に変更することができます。この機能を実際にご覧になりたい方は、多因子における RSM(Part1:基礎編) の手順に従ってください。

 

マウスのカーソルを等高線グラフ上に移動してください。カーソルの形状が十字(+)になります。Design-Expert の画面の左下隅に、予測される応答と座標が表示される点に注目しましょう。

画面の左下隅に表示される座標

 

等高線プロットの座標をより簡単に読み取るためのツールも用意されています。“View” -> “Show Crosshairs Window” を選択してください。

Crosshairs Windowの表示選択

 

もう一度、マウスのカーソルを等高線プロット上に移動してください。Design-Expert がカーソルの置かれた地点に対応する因子の特定の値に対して、予測される応答値を生成する点に注目しましょう。十字カーソルを実測点、例えば、重心の上部にあるチェック・ブレンド上(“A” のラベルが付いているところ)に移動すると、次に示すように、実測値(この事例では、35.100)も確認することができます。

実際の試行が行われた座標の予測

 

注意:Full ボタンをクリックすると、以下に示すように、座標と予測応答に加え、信頼区間と予測区間も表示できます。
CrosshairのFull表示

 

Crosshairs Window を閉じてください。

 

ズームインとズームアウト

仮に、粘度の最高値に関心があるとしましょう。マウスの左ボタンを押したまま、等高線グラフの右下隅にドラッグしてください。

ズーム指定された隅

 

これで、領域を選択した範囲が拡大表示されます。

ズームインした等高線プロットの領域

 

三角プロットの全体表示に戻すには、プロット上の任意の点を右クリックして、“Default View Window” を選択してください。

Default view window

 

注意: 等高線プロットの外観の変更向けに、さらに多くの機能が用意されています。これら機能の詳細については『多因子における RSM(Part 3:上級編)』の「見栄えの良い応答グラフを作成するヒントとコツ」を参照してください。

 

トレース プロット

ひとつの応答プロット上に、すべての因子を簡単に表示させることができれば便利ではないでしょうか?応答曲面のシルエット表示ができるトレースプロットを使えば、これを実現できます。このプロットの真のメリットは、等高線と 3D プロットの軸と定数項をこれによって選択できるようになることです。Graphs Toolbar にある “Trace” を選択してみましょう。トレースプロットは、各成分を変更したときの効果を参照ブレンド(デフォルトでは全体の重心)から頂点に伸びる架空のラインに沿って示します。例えば、曲線 A をクリックするとその色が変わります。

トレースプロット:成分Aが赤く強調表示されている

 

粘度(応答)は、この成分に対して影響が少ないことに注目してください。

注意: 実験領域が三角の単体で構成されているこの事例の場合は、Piepel か Cox のいずれの Direction をとるか迷うことは殆どありません。“View” -> “Trace Direction” を選び、“Cox” を選択し確認を行ってください。あるひとつの成分量が増えるに従って、それ以外の成分の合計量は減りますが、それらの構成比は依然として一定のままです。化学者であれば、反応化学量論を保持できるので、こちらを好むかも知れません。しかし、この方法でプロットすると、混合成分の制約条件が強い場合(化学反応のための溶媒など)は、トレースの先が断ち切られてしまいます。従って、混合計画の専門家は、現実の比率を一定に抑えることはできないけれども、Piepel を選ぶほうが最大限広範囲な実験空間をカバーできるため、Cox よりも役立つプロットを作成できると論じています。このため、Design-Expert では Piepel によるプロットを推奨しています。さらに詳しい情報につきましては、Help で “trace plot” を検索してください。
P.S. トレースプロットは、開始点をどこにするかによって大きく変化します(デフォルトは centroid/中心)。Factors Tool のスライドバーを動かしてご自身で確認してみてください。終了したら “Default” をクリックします。トレースが一次元のみであることが考慮されるため、とても実用的ではありますが応答曲面は表示されません。3D 応答プロットは、分かりやすい曲面を描画します。3D 応答プロットは最も望ましい混合成分を決定するための、まさに究極のツールなのです。

 

3種類以上の混合成分で実験を行う場合、トレースプロットを使用して、応答に最も影響を及ぼす成分を見つけ出します。見つけ出した影響力の大きい成分を等高線プロットの軸に選んでください。相対的に影響の小さい成分は定数項に設定してください。2D 等高線と 3D プロットは、これで視覚的に意味のある方法でスライスされるはずです。

注意: プロットに対して成分が3つ以上ある場合は、一定の軸を保持するために最適な構成がデフォルトで使用されます。例えば、4つの成分からなる計画をした場合、実験空間は4面体となります。この3次元の空間内で、いくつかの最適条件を発見するかも知れませんが、各最適条件で複数の三角形のスライスが必要です。

 

応答曲面の 3D 表示の作成

今度は、表示用に選択された2因子の関数として、応答が実際どのように変化するかを視覚的に見ていくことにしましょう。“View” -> “3D Surface” を選択してください。応答曲面が3次元で表示されます。実際の計画点が座標に含まれていれば、それらはグラフに表示されます。

3D 応答曲面プロット

 

3Dプロットは直接マウスでつかんで回転させることができます。グラフ上にマウスを置くと、カーソルが手に変わります。次に、マウスの左ボタンをクリックしたままドラッグします。実際に試してみてください。

 グラフ回転の試みが終わったら、Factors Tool の “Default” をクリックします。その後、グラフは元の状態にリセットされます。

注意: グラフを右クリックして、“Set Rotation” を選択し、3D 曲面プロットを任意の角度から簡単に表示させることができます。
3Dプロットを回転させるコントロールウィンドウ
水平(“h”)および垂直(“v”)の座標を指定できることに注目して、この機能を試してみてください。その後、Default をクリックし、X を押して回転ツールを終了してください。

 

Design-Expertは Graph Preferences を介して、3D グラフに対して様々なオプションを提供します。Graph Preferences は、プロットを右クリックしてメニューから選ぶことができます。例えば、カラーグラデーションで表示される曲面がどうしても気に入らない場合、Surface Graphs タブを選択し、3D graph shading を “wire frame view” に変更することができます(これによって見た目を透明にできます)。

 

 

応答予測

Design-Expert の応答予測は、Post Analysis ブランチの下に分類されています。この機能は、次のチュートリアルでより詳しく取り上げることになっていますが、これを使えば、あらゆる因子設定の予測応答を出力することができます。これがどのように機能するか確認してみましょう。動作を確認するには、“Point Prediction” ノードをクリックします。

Point Prediction

 

現在、単体の重心に位置する特定のブレンドの予測応答が、表示されているはずです。Factors Tool  は、Point Prediction Tool とともに表示されます。必要に応じて、上部の境界線をクリック&ドラッグして、ツールを移動させてください。component gauge 上のスライダーをドラッグすることで、別のブレンドも表示させることができます。この際混合物では、3つの成分の内2つだけを個別に変更できる点に注意してください。ここで、粘度の値が 43 になる組み合わせを、見つけることができますか(ヒント:尿素の値を少し押し上げてください)?ただしこの操作は、次のチュートリアルのセクションにて Design-Expertの最適化機能を利用して詳しく説明するので、あまりのめり込まないでください。

注意:Sheet ボタンをクリックすると、特定の成分の値を入力するのに便利な入力フォームを表示されます。ただし、この場合の原料の合計は必ず、前に指定した 9 wt%になるよう固定されているので気を付けてください。値を入力するたびに、Design-Expert は恐らくあなたが予想もしない方法で調整を行います。元の値が分からなくなってしまっても、“Default” ボタンをクリックすればいつでも重心の位置に戻ることができるので、心配はいりません。

 

2番目の応答データの分析

この最後の一歩は大きな前進です。2番目の応答、すなわち濁度(Y2)に関するデータの分析です。ご自身でデータの当てはめに相応しい多項式を選び、その残差を調べたら、応答曲面プロットを作成するようにしてください(ヒント:正しいモデルは特殊3次になります)。

 プログラムを終了する前に、分析した内容が失われないよう “File” -> “Save” を実行してください。これにより Design-Expert に作成したモデルが保存されます。Design-Expert を閉じるには、File メニューの Exit を使います。内容の変更されたファイルが他にある場合は、もう一度保存するようプログラムから警告が表示されます。

 このチュートリアルは、Design-Expert で混合物の計画をはじめる良い機会です。引き続き、次のチュートリアル、混合計画の最適化へ進むと良いでしょう。また、プロセス変数を応答曲面法(RSM)に適用するチュートリアルも学びたくなるかもしれません。混合計画についてより詳細に学びたい場合は、Stat-Ease 社が主催する大規模なワークショップ「Mixture Design for Optimal Formulations」に参加してください。スケジュールについては、Stat-Ease 社に電話をするか、Webサイトにアクセスしてください。