ヒューリンクステクニカルサポート
Design-Expert サポート情報 Design-Expert 製品ページ
更新日: 21/01/13

3. 計画の評価

Design-Expert には、RSM 計画を評価する強力なツールが用意されています。計画の評価は、応答データを収集する前段階でなされるべきことですが、事後的に行うことも可能です。例えば、計画した設定点に明らかな偏差があり、それを反映させるために因子水準に変更を加える必要があることに気がつくかもしれません。あるいは、試行数が全く足りないかもしれません(少なくとも応答の一部について)。そのような場合は、計画を再評価してその損害を調べる価値があるでしょう。

これまでになされた内容を確認してみましょう。“Design” ブランチの “Summary” ノードをクリックしてください。

計画のサマリー

 

この計画のサマリーには、計画タイプとして中心複合計画(CCD: central composite design)がブロック数2で選択され、モデルとして2次の当てはめが適用されていることがレポートされています。“Evaluation” ノードをクリックしましょう。Design-Expert では、この計画で使用するモデルの次数が既に仮定されていることをご確認ください。

計画の評価:Model 選択

 

“Results” タブをクリックして、最初のレポートを表示してみましょう。デフォルトでは注釈が表示されます。

計画の評価結果(“View” -> “Show Annotation” を選択した状態)

 

ここで様々なペインに目を通して、結果が非常に良好であることをご確認ください。標準的な RSM 計画で期待される内容と同じです。

非常に悪い因子行列について: 計画の評価が遥かに悪い場合は、「RSM に対するヒストリカルデータの適応(Part2)」をご覧ください。

 

画面上の “Graphs” タブをクリックして、次に進みます。デフォルトで表示されるのは、標準誤差と設計空間率との関係を表す FDS グラフに設定されています。表示された曲線をクリックしてみましょう。Design-Expert には、二つの関係を読み取りやすくするための座標ラインが表示されます。

FDS(設計空間率)グラフをクリックして座標を表示

 

FDS グラフの “y” 軸は、実験領域の大量のサンプリングに基づいて(凡例に表示されているようにデフォルトで設定されるのは 150,000 ポイント)、全空間内の任意の構成比において予測される最大の変動幅を数値で表します。例えば、画面左側の凡例に記載されているように、この応答曲面法(RSM)計画の割合が 80% のところでは、標準誤差(SE)の値がおよそ 0.5 以下となっています。なお、無作為サンプリングアルゴリズムにより実際の FDS は若干異なる場合がありますのであらかじめご了承ください。別の計画と評価を比べる場合は、FDS 曲線が低くて平らな方を優先してください。

注意: どのくらい正確な応答の予測が必要であるかに基づいて FDS は RSM 計画を形成する仕組みを提供します。Stat-Ease 社では RSM のワークショップでその手法を提供しています。詳細については、次のリンクから “Practical Aspects of Algorithmic Design of Physical Experiments” の PDF 資料を参照してください。

 

FDS では、予測能力に関する情報が提供されます。計画の “rotatability”(回転可能性)基準を見てみましょう。“View” -> “contour” を選択してください。Design-Expert には、標準誤差プロットが表示されます。これは、予測に関する分散が設計空間全体にどう影響するかを表すものです。

標準誤差の等高線プロット

 

これを見れば、中心複合計画(CCD)によって 6つの中心点の周囲の広い範囲で、比較的精度の高い予測が得られることを確認できます。また、等高線が円形である点についても注意してください。これは望ましい回転可能特性を表します。この RSM 計画では、中心点からの距離が等しいと、それに対応する予測力の精度も等しくなります。Design-Expert の標準誤差プロットでは、デフォルトでモノクロのグラデーションが設定されています。通常応答の等高線プロットがあまりにもカラフルになるようなグラデーションは、標準誤差の表示には不向きです。このグラフの四隅をよくご覧ください。グレーになっているのを確認できると思います。これは、応答を精確に予測できない領域が表示されていることを示しています。

中心複合計画の外側領域について: 標準誤差プロットは、応答プロットと同様に操作することができます。実験範囲を拡張すると、どうなるか見てみましょう。“Display Options” -> “Process Factors” -> “Coded” を選択してください。次に、グラフ上で右クリックし、“Edit axes...” を選択します。デフォルトで指定された X1 Axis の下限値 Low「-2」に、上限値 High を 「2」 に変更してください。次に、X2 Axis タブをクリックし、下限値 Low「-2」に、上限値 High「2」に変更してください。以上の設定変更が完了したら、“OK” をクリックしてください。
標準誤差の等高線プロットの軸を拡張し、推定領域がシェーディングされている
色調からお分かりのとおり、シェーディングは標準偏差の半分から始まり、標準偏差の最大 1.5 倍まで線形的に増加しています。規定の要因範囲内(±1)であればシェーディングはこのように一定の明るさが保持されます。しかし、それ以上拡大させると、暗くなります。このように暗くなった領域の予測には警戒してください!この補足的探索を終了する前に、Graph Preferences にもどり、両軸をデフォルトに戻してください。また、因子についても元の水準に戻してください。

 

それでは、Graphs Tool“3D Surface” をクリックしてみましょう。

標準誤差の3D表示

 

標準誤差の3Dプロット(Y軸を再度スケーリングしたもの)

 

標準誤差を表すこのボウル状の曲面の底が、平坦になっている点に注目してください(このプロットの底は Y 軸の low を 0.4 にし、high を 0.8 に変更することで作成されました)。この形状は、RSM 計画にとって非常に望ましいものです。まさに理想的な出来栄えです。