ヒューリンクステクニカルサポート
Design-Expert サポート情報 Design-Expert 製品ページ
更新日: 21/01/13

6. グラフによるモデルの調査

残差の診断から統計的な不都合はないことがわかりましたので、それではいよいよ、応答曲面プロットを作成することにしましょう。“Model Graphs” タブをクリックしてください。デフォルトで表示されるのは段階的なカラーグラデーションで彩色された因子 A 対因子 B の 2D 等高線プロットです。

応答曲面等高線プロット

 

多因子空間で計画の点 (ポイント) を視覚化するには: Design-Expert では、設計空間に含まれるすべての実測点 が表示される点に注意してください。ここに表示されているプロットは、時間と温度の関数として表された反応率が触媒 (因子 C) の中間水準でスライスされたものです。この断面には、等高線プロット中央の赤い点に示されているように、中心点が6つあります。中心点の繰り返しによって、実験領域の中間地点の予測力が非常に高くなります。

 

デフォルトのプロットとともに、 Factors Tool は右側に表示されます。必要に応じて、ウインドウ上部の青い縁をマウスでクリック&ドラッグすることで移動できます(画面右側にドラッグして元の位置に戻すこともできます)。このツールを使って、グラフにプロットさせたい因子を制御します。

Factors Tool の機能について: リストアップされた各因子には、現在グラフに表示されていることを示す軸ラベル、もしくは、現在プロットされていない因子に対する特定の設定を選択できるスライドバーが用意されています。スライドバーの水準のデフォルトは、いずれも現在軸に指定されていない因子の中間点が指定されています。スライドバーをマウスでドラッグするか、因子の名称をマウスで左クリックしてそれを選択状態にし(強調表示されます)、ツールパレットの下側に用意された数値領域に変更したい水準を入力することで、因子の水準を変更することができます。是非試してください。

 

“C:Catalyst” ツールバーをクリックして、その値を確認してみましょう。スライドバーが多少ずれていても気にしないでください。一瞬でこれをリセットする方法を後で紹介します。

因子 C を選択してその値が表示されている Factors Tool

 

バーをマウスで左クリックしたら、それを右にドラッグしてください。

因子Cのスライドバーを右側に移動させて、その値を高くする

 

画面左側のカラーキーが示すように、曲面の応答水準が高いところほど「hot (熱く)」なっており、80%台では黄色に、90%以上では赤となっています。

Crosshairs ツールを使用してグラフの座標を検討する: ここで、等高線プロットの座標を調べるのに便利なツールを有効にしてみましょう。“View” メニューの “Show Crosshairs Window” を選択してください(画面の左側からタイトルバーの固定を解除する場合は、タイトルバーをクリックしてドラッグします)。それでは、等高線プロット上でマウスを動かしてみましょう。Design-Expert は、その地点に対応する因子の特定の値の予測応答値を生成することに注意してください。例えば、実測点(現在グラフの画面左上の隅にあるものです)上に十字カーソルを動かすと、その実測値も一緒に表示されます(この場合は 66 です)。
実際に実験が行われた地点の座標 (40,90) における予測値
P.S. Crosshairs ツールで、Full オプションを押した場合の動作を確認してみてください。

 

それでは、 Factors Tool にある Default ボタンをクリックして、因子 C の位置を中央の水準に戻します。

Factors Tool おける Sheet 表示について: Factors Tool の Sheet ボタンをクリックして、表示を Factors Sheet に切り替えてみましょう。
Factors sheet
列名が Axis と Value のシートでは、右クリックして軸の設定を変更したり、因子の値を具体的に入力することができるので試してみてください。次にウインドウを閉じて、“Default” ボタンを押してください。
P.S. Factors Tool の下には、プロットしたい因子を選べるプルダウンリストがあります。リストでは、モデル内に存在する項だけが選択肢として含まれています。このチュートリアルでは、この時点でこれを AB に設定する必要があります。ある1因子(例えば A)を選択すると、グラフは1因子プロットに変わります。よろしければ、この操作を試してみてください。ただし、交互作用に含まれる主効果をプロットした場合、どのような警告が表示されるか注意してください。

 

摂動 (Perturbation) プロット

単一の応答プロットだけで全ての因子を簡単に把握したいとは思いませんか?応答曲面のシルエットを表示する摂動プロットを使えば、これを実現できます。等高線プロットや3Dプロットで軸と定数を選ぶときは、このプロットを使うまさに絶好の機会です。Graphs Tool にマウスを移動し “Perturbation” を押すか、メインメニューから “View” -> “New Graph” を指定して確認してください。

摂動プロットで因子Aをクリックして強調表示にした

 

応答曲面計画の場合、摂動プロットは、ある因子を指定した参照点から移動させることによって応答がどのように変化するかを示します。このとき他のすべての因子の値は参照値で固定されています。Design-Expert で指定される参照点は、通常、設計空間の中央がデフォルトとなります(コード化された各因子水準のゼロの地点)。  

因子 A の曲線をクリックすると、見やすくなります。選択した曲線は上の図に示すように異なる色で強調表示されます。このとき、凡例も一緒に協調表示されます。この場合、中心点で因子 A(Time)を参照点から移動させることによって、それが生み出す効果は比較的小さいことを確認できます。従って、等高線には一度に2つの因子しかプロットすることはできないので、ここでは、因子 B と C を選ぶのが良いことになります。因子 A はスライスに使います。

 

等高線プロット:再考

それでは、因子 B と C からなるプロットを見てみましょう。まず、Graphs Toolbar から “Contour” をクリックして開始します。Factors Tool にある “Catalyst” バーを右クリックして、“X1 axis” を選択します。

因子 C を x1 軸に指定する

 

現在、反応率に関する触媒対温度のプロットを画面上に確認できるはずです。このとき、時間はその中央点が定数に適用されています。

B:温度 対 C:触媒のContourプロット

 

Design-Expert のContourプロットは非常にインタラクティブです。例えば、中央上部のホットスポットで右クリックして、“Add Flag” を選択してみてください。

フラグの追加

 

今のところ、等高線プロットに関する知識はこれで十分です - その他のヒントやコツ、さらに体裁を良くする手法に関しては、このチュートリアルのパート3 で説明します。右クリックして “Delete Flag” を使用し、元に戻します。