ヒューリンクステクニカルサポート
更新日: 16/03/31

GINO GUI LITE 8.0 の使い方

関連:GINO GUI LITE 8.1 の使い方

Absoft Pro Fortran の Windows 版に無料でバンドルされている GINO GUI LITE は、GINOMENU(プログラム用ライブラリ)と GINOMENU Studio(GUI 作成ツール)を持った GINO GUI 正規版と同機能の GUI 作成ソフトウェアです。1プログラム当り最大 150 ウィジットという制限がありますが、それ以外は正規版とまったく同等のパッケージを利用することができます。

使用するには、Windows XP、Vista、7 と Absoft Pro Fortran for Windows v10.2.2 および v11.1 以上が必要です。

備考:

<GINOインストール先 > GINO をインストールしたフォルダです。

  • c:\program files\gino\v8.0
    (32ビット Windows のデフォルトインストール先)
  • c:\program files (x86)\gino\v8.0
    (64ビット Windows のデフォルトインストール先)

<GINOサンプルデータ> GINOのサンプルデータが置かれた examples フォルダです。

  • c:\Documents and Settings\{user}\My Documents\gino\v8.0\examples
    (Windows XP)
  • c:\Users\{user}\Documents\gino\v8.0\examples
    (Windows Vista/Windows 7)

 

 

環境変数の設定

インストール後、レジストリの環境変数がアップデートされていない場合は、以下のように設定して下さい。

コマンドプロンプトのウィンドウをすでに開いている場合は、いったんウィンドウを閉じ、再度起動しないと変更が反映されません。

この設定は、GINO のインストル先の最上位フォルダにある GINOVARS.BAT ファイルにも記述されています。

Absoft Developer Tools Interface で GINO を使用する

  1. Developer Tools Interface を起動する前に、環境変数の Path に GINO のインストール先が設定されていることを確認して下さい。

  2. Developer Tools Interface を起動したら、ProjectNew Project メニューコマンドをクリックして、プロジェクトオプション(プロジェクト名、ターゲットファイル、プロジェクトディレクトリ)を設定して下さい。

  3. FORTRAN オプションパネルを開き、Module Paths の入力フィールドに「<GINOインストール先>\modules」を入力して下さい。

  4. Linker オプションパネルを開き、Additional Options の入力フィールドに「 -subsystem:windows」と入力して OK ボタンを押します。

  5. ProjectAdd Files メニューコマンドをクリックして、ソースフィアルを読み込みます。 (例:<GINOサンプルデータ>\menu\hello.f90 ファイルを読み込みます。)

  6. 必要な GINO ライブラリファイルを、ProjectAdd Files メニューコマンドで読み込みます。<GINOインストール先>へ行き、以下のファイルを追加します。

    Gui Lite 版の場合: WINMAIN.OBJ、GMENULAB.LIB、GMWINERR.LIB、WINGUIAB.LIB、MINIGAB.LIB

  7. Build ボタンを押してプロジェクトをビルドし、Run ボタンでプログラムを実行して下さい。

GINOMENU Studio 開発環境で GINO を使用する

GINOMENU Studio を使用する場合、Absoft Fortran コンパイラ、および GINO のカレントディレクトリで作業することが必要です。GINO の環境変数が正しく設定されているか確認した後、Absoft Pro Fortran の Development Command ウィンドウから GINOMENU Studio を起動します。

  1. スタートAbsoft Pro Fortran XXXXDevelopment Command Prompt (32bit) メニューコマンドをクリックして、Absoft Pto Fortran のコマンドウィンドウを開いて下さい(XXXX はバージョン番号です)。

  2. cd コマンドを使って <GINOサンプルデータ>¥mstudio フォルダに移動して下さい。

  3. mstudio を入力して Enter キーを押すと、GINOMENU Studio が起動します。


  4. GINOMENU Studio の FileOpen Project メニューコマンドを使ってサンプルデータ Hello.gsp ファイルを開いて下さい。

  5. プロジェクトが読み込まれたら <F5> キーを押すと、コンパイル、リンク、プログラムが実行されます。

  6. もし「The directory name is invalid」というエラーメッセージが表示された場合は OK ボタンを押し、メインツールバーにある「F90」アイコンをクリックしてソースコードをカレントディレクトリに保存し、再度<F5>キーをクリックして下さい。

  7. さらに保存場所のダイアログが表れた場合は、SAVE ボタンを押して下さい。

  8. また上書きするか尋ねてきた場合は、YES を選択して下さい。

  9. サンプルプログラムがコンパイルとリンクをされたら、直ちに実行されます。実行されたプログラムのウィンドウは、デザインウィンドウの横に表示されますので、注意して見て下さい。実行ウィンドウとデザイン中のフォームの違いは、以下の通りです。

    1. プログラム実行中のウィンドウには、グリッドのドットが背景にありません。
    2. プログラム実行中のウィンドウが、最初デザインウィンドウよりも上に表示されます。
    3. Abort Execution ボタンが ON(赤色)になっている場合は、プログラムが実行中です。

Absoft Pro FortranコマンドウィンドウでGINOを使用する

GINO のサンプルプログラムをビルドするためバッチファイル(MENUBLD.BAT)を用意しました。Absoft Pro Fortran の Development Command ウィンドウからこれを実行して下さい。

バッチファイルは、GINO インストール先の最上位ディレクトリにあり、環境変数の Path が正しく設定されていれば、バッチコマンドは必ず実行できます。ここでは、 GINOMENU のサンプルプログラム(Draw.f90)をコンパイル、リンク、そして実行してみましょう。

  1. スタートAbsoft Pro Fortran XXXX Development Command Prompt (32bit) メニューコマンドをクリックして、Absoft Pto Fortran のコマンドウィンドウを開いて下さい(XXXX はバージョン番号です)。

  2. もし環境変数が設定されていない場合は、以下のようにして ginovars バッチコマンドを実行して下さい。 環境変数が設定されます。

    1. C:\> cd <GINOインストール先>
    2. C:\> ginovars

  3. 環境変数の設定が終わったら、cd コマンドを使用して <GINOサンプルデータ>\menu フォルダに移動して下さい。

  4. バッチコマンドを以下のように入力し、実行して下さい(引数 draw が必要です)。

     <GINOサンプルデータ>\menu> menubld draw


64 ビット機で GINO を使用する

GINO を 64ビット Windows が動作している環境にインストールした場合は、GINO の 32 ビット版が c:\program files (x86)\gino\... にインストールされます。Absoft Pro Fortran のコマンドウィンドウは、Development Command Prompt (32bit) の方を使用して下さい。