HOME > テクニカルサポート > 製品一覧 > ChemOffice シリーズ
ヒューリンクステクニカルサポート
皆様からのご質問のうち、よくある質問を掲載しました。
ChemOffice シリーズ サポート情報 ChemOffice シリーズ製品ページ
更新日: 16/10/26

ハイパーリンクを追加する操作方法 - ChemFinder

"Table Script” を介してサブフォーム内にハイパーリンクを表示できます。

リンクのためにテキストエントリの列を持つテーブルを作成する必要があり、メインのレコードにリンクするため、ID の別の列のサブフォーム内にリンクを表示します。

(以下 ChemFinder のサンプルデータを使用して操作手順を説明します。)

  1. ChemFinder Form で、Subform を作成します。
    (レイアウトモードで左のツールメニュー下から 4番目のアイコンを選択しウィンドウ上でドラッグ。)


  2. Subform Properties ダイアログの「Table」タブにある「Create Table...」ボタンをクリックすることで新しいテーブルのサブフォームのためのデータソースを設定します。



  3. 新しいテーブルを呼びだし、URL を設定します。

  4. 「Field」タブ内の「Create Field...」をクリックして、「URL」という新しいテキストフィールドを作成します。



  5. 「Subform」タブ内で、メインテーブルとサブテーブル間にリンクを設定します。


  6. また、「Subform」タブで、Table script フィールド横の「Edit..」ボタンを押します。


  7. 起動したスクリプトエディタダイアログで、「CAL」ラジオボタンを選択し、次のスクリプトを入力します。
    getdata 1 URL
    launch $v1



  8. OK をクリックして Subform Properties ダイアログに戻ります。

  9. 「Form」タブで、「Generate form」チェックボックスを選択し、OK をクリック。


  10. テーブルに必要なレコードを追加します。(ビューモードにして ID、URL を個々に入力)
    フィールドのボックスを非表示にすることもできます。


  11. サブフォーム内をクリックし、アクティブなフォームにして Data Table 表示にするためにビューを設定します。 (View → Switch View を選択)


  12. 入力した URL がハイパーリンクであることを確認する必要があります。リンクをクリックすることで、デフォルト Webブラウザが開きそのサイトを表示します。

 

このサブフォームにファイルからレコード追加する場合

Excel (またはテキスト) ファイルにデータ入力します。

MS Access を起動して、使用中の Accessデータベースファイル xxxxx.mdb を開き、左のリストの任意のテーブルを右クリック&インポートを選択して、Excel (テキスト) ファイルを読み込むことで、ChemFinder 上に追加できます。

 

前のページにもどる